summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2006-06-06 18:52:54 +0000
committerThilo Bangert <bangert@gentoo.org>2006-06-06 18:52:54 +0000
commit53af0fd5f1b360836d3a6545d094335c62f04098 (patch)
tree0afcf9350a5e286b1a4111888e31c50eed67f8d8 /www-servers
parentAdded ~ppc, bug #135397 (diff)
downloadhistorical-53af0fd5f1b360836d3a6545d094335c62f04098.tar.gz
historical-53af0fd5f1b360836d3a6545d094335c62f04098.tar.bz2
historical-53af0fd5f1b360836d3a6545d094335c62f04098.zip
fix compile on gcc-4.1.1 (bug #135317) - add warning about the need to re-merge when switching from app-admin/fam to app-admin/gamin and vice versa
Package-Manager: portage-2.0.54-r2
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/lighttpd/ChangeLog9
-rw-r--r--www-servers/lighttpd/Manifest5
-rw-r--r--www-servers/lighttpd/files/1.4.11/23_all_mod_ssi_gcc-4.1.1_compile_fix.diff12
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.11.ebuild7
4 files changed, 29 insertions, 4 deletions
diff --git a/www-servers/lighttpd/ChangeLog b/www-servers/lighttpd/ChangeLog
index c17d8992d6c1..8d9651f65ee8 100644
--- a/www-servers/lighttpd/ChangeLog
+++ b/www-servers/lighttpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/lighttpd
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/ChangeLog,v 1.75 2006/06/03 12:33:17 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/ChangeLog,v 1.76 2006/06/06 18:52:54 bangert Exp $
+
+ 06 Jun 2006; Thilo Bangert <bangert@gentoo.org>
+ +files/1.4.11/23_all_mod_ssi_gcc-4.1.1_compile_fix.diff,
+ lighttpd-1.4.11.ebuild:
+ fix compile on gcc-4.1.1 (bug #135317)
+ add warning about the need to re-merge when switching
+ from app-admin/fam to app-admin/gamin and vice versa
03 Jun 2006; Thilo Bangert <bangert@gentoo.org>
-files/1.4.10/05_all_r996_fallback_to_madvise.diff,
diff --git a/www-servers/lighttpd/Manifest b/www-servers/lighttpd/Manifest
index 57f9b0c3a9b0..c0853120054e 100644
--- a/www-servers/lighttpd/Manifest
+++ b/www-servers/lighttpd/Manifest
@@ -1,9 +1,10 @@
-MD5 4936d909b7efe8c5f5067a8f0b822465 ChangeLog 23320
+MD5 c271e2943ac2a2722a59ad1fb3293de1 ChangeLog 23608
MD5 1b3bebe51407cf5a2f406a53465d9901 files/1.4.11/01_all_r1046.mod_compress.c-fixes.diff 5992
MD5 322a27dd300158534f8cb65ffad9e03d files/1.4.11/02_all_r1057_fix_If-Modified-Since-ETag.diff 2464
MD5 efe7fb8d01b34d2bef55f80b450f7a86 files/1.4.11/03_all_r1095_fix_stalling_SSL_POST_requests.diff 500
MD5 560787bd4caa409af1cebdb03a76bebc files/1.4.11/21_all_mod_scgi_segfault.diff 458
MD5 d1027d3e457185a382d4f6457e95bb3b files/1.4.11/22_all_bug606_fix_SSI_echo.diff 4905
+MD5 0ce285405a1c07a6f7cf2905a056f299 files/1.4.11/23_all_mod_ssi_gcc-4.1.1_compile_fix.diff 353
MD5 df5b2360ea380d988bf16905ab214286 files/conf/lighttpd.conf 8182
MD5 fef397e7bcf1b741dea211a555e1803c files/conf/mime-types.conf 3291
MD5 9c1407e95f62ed22da66c4ef5f69c3b5 files/conf/mod_cgi.conf 869
@@ -20,5 +21,5 @@ MD5 ad091c9157134890499f26d170352c9f files/lighttpd.logrotate 487
MD5 1d925aed297ec4541fb230dd19e11bc1 files/spawn-fcgi.confd 1076
MD5 e605a4ead0ce7b1e0788c0b0b1161871 files/spawn-fcgi.initd 1383
MD5 0df89754aec138ad20821ef93c45833b lighttpd-1.3.16.ebuild 2589
-MD5 778d1ba0e24be3791d6c052d9d322956 lighttpd-1.4.11.ebuild 5208
+MD5 45841ff6eb15ba7004fa71ea40ffa491 lighttpd-1.4.11.ebuild 5355
MD5 6a9d4814404d8d51327e5b8306ee3d7e metadata.xml 726
diff --git a/www-servers/lighttpd/files/1.4.11/23_all_mod_ssi_gcc-4.1.1_compile_fix.diff b/www-servers/lighttpd/files/1.4.11/23_all_mod_ssi_gcc-4.1.1_compile_fix.diff
new file mode 100644
index 000000000000..4991bc52a263
--- /dev/null
+++ b/www-servers/lighttpd/files/1.4.11/23_all_mod_ssi_gcc-4.1.1_compile_fix.diff
@@ -0,0 +1,12 @@
+--- lighttpd-1.4.11.orig/src/mod_ssi.c
++++ lighttpd-1.4.11/src/mod_ssi.c
+@@ -36,6 +36,9 @@
+ #include <sys/filio.h>
+ #endif
+
++static int mod_ssi_handle_request(server *srv, connection *con, plugin_data *p);
++static int mod_ssi_patch_connection(server *srv, connection *con, plugin_data *p);
++
+ /* determine if process finished */
+ int h_finished = 0;
+
diff --git a/www-servers/lighttpd/lighttpd-1.4.11.ebuild b/www-servers/lighttpd/lighttpd-1.4.11.ebuild
index 7e481d4878b7..a68b6d780023 100644
--- a/www-servers/lighttpd/lighttpd-1.4.11.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.4.11.ebuild,v 1.4 2006/06/01 21:56:36 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.4.11.ebuild,v 1.5 2006/06/06 18:52:54 bangert Exp $
inherit eutils autotools depend.php
@@ -193,5 +193,10 @@ pkg_postinst () {
ewarn "existing configuration."
ebeep 5
fi
+
+ if use fam ; then
+ einfo "Remember to re-emerge lighttpd should you switch from"
+ einfo "app-admin/famd to app-admin/gamin or vice versa."
+ fi
echo
}