summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-08-08 06:28:13 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-08-08 06:28:13 +0000
commit9320443950a24564d84da3dfc93e586fdfc657b1 (patch)
tree985eef46960083a3b1d79db48f04c8de8b4a1423 /x11-apps/xfd
parentversion bump (diff)
downloadhistorical-9320443950a24564d84da3dfc93e586fdfc657b1.tar.gz
historical-9320443950a24564d84da3dfc93e586fdfc657b1.tar.bz2
historical-9320443950a24564d84da3dfc93e586fdfc657b1.zip
Initial commit for modular X.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'x11-apps/xfd')
-rw-r--r--x11-apps/xfd/ChangeLog9
-rw-r--r--x11-apps/xfd/Manifest2
-rw-r--r--x11-apps/xfd/files/digest-xfd-0.99.01
-rw-r--r--x11-apps/xfd/xfd-0.99.0.ebuild24
4 files changed, 36 insertions, 0 deletions
diff --git a/x11-apps/xfd/ChangeLog b/x11-apps/xfd/ChangeLog
new file mode 100644
index 000000000000..d446e91c59dd
--- /dev/null
+++ b/x11-apps/xfd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-apps/xfd
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfd/ChangeLog,v 1.1 2005/08/08 06:28:11 spyderous Exp $
+
+*xfd-0.99.0 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; +xfd-0.99.0.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-apps/xfd/Manifest b/x11-apps/xfd/Manifest
new file mode 100644
index 000000000000..eb62dad5ae1f
--- /dev/null
+++ b/x11-apps/xfd/Manifest
@@ -0,0 +1,2 @@
+MD5 4ed48ce65d9531a4ebb763298e17e689 xfd-0.99.0.ebuild 562
+MD5 0a7afb456adad031438816c42636154f files/digest-xfd-0.99.0 62
diff --git a/x11-apps/xfd/files/digest-xfd-0.99.0 b/x11-apps/xfd/files/digest-xfd-0.99.0
new file mode 100644
index 000000000000..c8f2cc94cde2
--- /dev/null
+++ b/x11-apps/xfd/files/digest-xfd-0.99.0
@@ -0,0 +1 @@
+MD5 af1c4bb1fa712f3c31e8a2c2fe7ddfb4 xfd-0.99.0.tar.bz2 65240
diff --git a/x11-apps/xfd/xfd-0.99.0.ebuild b/x11-apps/xfd/xfd-0.99.0.ebuild
new file mode 100644
index 000000000000..3c11adfbfd4d
--- /dev/null
+++ b/x11-apps/xfd/xfd-0.99.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfd/xfd-0.99.0.ebuild,v 1.1 2005/08/08 06:28:11 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xfd application"
+KEYWORDS="~x86"
+# xprint support isn't optional, despite what configure says.
+#IUSE="xprint"
+RDEPEND="=media-libs/freetype-2*
+ media-libs/fontconfig
+ x11-libs/libXft
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}