summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-01-21 10:38:03 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-01-21 10:38:03 +0000
commit6ba12e209b9a7bc8a85ca12e948ef3bcec15d754 (patch)
tree6a26fc5e3321c0a26f6400dc4bbf3d5875747543 /x11-libs/libdockapp/libdockapp-0.6.1.ebuild
parentAdded ppc keyword. bug 119436 (diff)
downloadhistorical-6ba12e209b9a7bc8a85ca12e948ef3bcec15d754.tar.gz
historical-6ba12e209b9a7bc8a85ca12e948ef3bcec15d754.tar.bz2
historical-6ba12e209b9a7bc8a85ca12e948ef3bcec15d754.zip
Version bump, see bug #119300.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'x11-libs/libdockapp/libdockapp-0.6.1.ebuild')
-rw-r--r--x11-libs/libdockapp/libdockapp-0.6.1.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/x11-libs/libdockapp/libdockapp-0.6.1.ebuild b/x11-libs/libdockapp/libdockapp-0.6.1.ebuild
new file mode 100644
index 000000000000..a43f4ef66db5
--- /dev/null
+++ b/x11-libs/libdockapp/libdockapp-0.6.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libdockapp/libdockapp-0.6.1.ebuild,v 1.1 2006/01/21 10:38:03 nelchael Exp $
+
+inherit eutils autotools
+
+IUSE=""
+
+DESCRIPTION="Window Maker Dock Applet Library"
+SRC_URI="http://solfertje.student.utwente.nl/~dalroi/libdockapp/files/${P}.tar.bz2"
+HOMEPAGE="http://solfertje.student.utwente.nl/~dalroi/libdockapp/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xextproto
+ x11-proto/xproto )
+ virtual/x11 )"
+
+S=${WORKDIR}/${P/lib/}
+FONTDIR="/usr/share/fonts/${PN}-fonts"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # sanitize fonts installation path
+ epatch ${FILESDIR}/install-paths.patch-${PV}
+
+ # add legacy support for older dockapps
+ epatch ${FILESDIR}/legacy.patch-${PV}
+}
+
+src_compile()
+{
+ eautoreconf
+
+ econf || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install()
+{
+ make \
+ DESTDIR=${D} \
+ SHAREDIR="${D}/usr/share/doc/${PF}/examples/" \
+ install || die "make install failed"
+
+ dodoc README ChangeLog NEWS AUTHORS
+}
+
+pkg_postinst()
+{
+ einfo
+ einfo "You need to add following line into 'Section \"Files\"' in"
+ einfo "/etc/X11/xorg.conf (or /etc/X11/XF86Config if you are still using XFree86)"
+ einfo "and reboot X Window System, to use these fonts."
+ einfo
+ einfo "\t FontPath \"${FONTDIR}\""
+ einfo
+ einfo "You also need to add the following line to /etc/fonts/local.conf"
+ einfo
+ einfo "\t <dir>${FONTDIR}</dir>"
+ einfo
+}
+
+pkg_postrm()
+{
+ einfo
+ einfo "You need to remove following line from 'Section \"Files\"' in"
+ einfo "/etc/X11/xorg.conf (or /etc/X11/XF86Config if you are still using XFree86)"
+ einfo "to unmerge this package completely."
+ einfo
+ einfo "\t FontPath \"${FONTDIR}\""
+ einfo
+ einfo "You also need to remove the following line from /etc/fonts/local.conf"
+ einfo
+ einfo "\t <dir>${FONTDIR}</dir>"
+ einfo
+}