summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-04-03 05:14:34 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-04-03 05:14:34 +0000
commit7a584b0994423c1a248aa8ffa1ada70a757b3323 (patch)
treeee0e2cf22d3d5f21e748f9de8260e272a594842c /x11-plugins/compiz-plugins-extra
parentReplaced compiz ~ deps with >= deps to support the new compiz-0.8.6 release a... (diff)
downloadhistorical-7a584b0994423c1a248aa8ffa1ada70a757b3323.tar.gz
historical-7a584b0994423c1a248aa8ffa1ada70a757b3323.tar.bz2
historical-7a584b0994423c1a248aa8ffa1ada70a757b3323.zip
Replaced compiz ~ deps with >= deps to support the new compiz-0.8.6 release and to avoid future dep issues.
Did a revbump to avoid issues with installed packages. Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'x11-plugins/compiz-plugins-extra')
-rw-r--r--x11-plugins/compiz-plugins-extra/ChangeLog12
-rw-r--r--x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6.ebuild65
2 files changed, 75 insertions, 2 deletions
diff --git a/x11-plugins/compiz-plugins-extra/ChangeLog b/x11-plugins/compiz-plugins-extra/ChangeLog
index 1d363c07c3d2..d4a041fecf9a 100644
--- a/x11-plugins/compiz-plugins-extra/ChangeLog
+++ b/x11-plugins/compiz-plugins-extra/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/compiz-plugins-extra
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/ChangeLog,v 1.10 2009/12/23 02:48:15 jmbsvicetto Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/ChangeLog,v 1.11 2010/04/03 05:11:17 jmbsvicetto Exp $
+
+*compiz-plugins-extra-0.8.6 (03 Apr 2010)
+
+ 03 Apr 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +compiz-plugins-extra-0.8.6.ebuild:
+ Replaced compiz ~ deps with >= deps to support the new compiz-0.8.6
+ release and to avoid future dep issues.
+ Did a revbump to avoid issues with installed packages.
23 Dec 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
compiz-plugins-extra-0.8.4.ebuild, compiz-plugins-extra-0.8.4-r1.ebuild:
diff --git a/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6.ebuild b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6.ebuild
new file mode 100644
index 000000000000..78663a1bcb23
--- /dev/null
+++ b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6.ebuild,v 1.1 2010/04/03 05:11:17 jmbsvicetto Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="Compiz Fusion Window Decorator Extra Plugins"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gnome"
+
+MY_PV="0.8.4"
+
+RDEPEND="
+ >=gnome-base/librsvg-2.14.0
+ media-libs/jpeg
+ >=x11-libs/compiz-bcop-${MY_PV}
+ >=x11-plugins/compiz-plugins-main-${PV}
+ >=x11-wm/compiz-${PV}
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ >=sys-devel/gettext-0.15
+ x11-libs/cairo
+ gnome? ( gnome-base/gconf )
+"
+
+src_prepare() {
+ use gnome || {
+ epatch "${FILESDIR}"/${PN}-no-gconf.patch
+
+ # required to apply the above patch
+ intltoolize --copy --force || die "intltoolize failed"
+ eautoreconf || die "eautoreconf failed"
+ }
+}
+
+src_configure() {
+ econf --disable-dependency-tracking \
+ $(use_enable gnome schemas)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_preinst() {
+ if use gnome; then
+ gnome2_gconf_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gnome; then
+ gnome2_gconf_install
+ fi
+}