summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-12 10:44:27 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-12 10:44:27 +0000
commitbfae2785546de756f9801e3d5ec8380c0f4aa78c (patch)
tree5805d30ca8a604543be0b7ed7f5181dbc9b3270c /x11-plugins/gkrellmss/gkrellmss-2.3.ebuild
parentnew viewer for X (diff)
downloadhistorical-bfae2785546de756f9801e3d5ec8380c0f4aa78c.tar.gz
historical-bfae2785546de756f9801e3d5ec8380c0f4aa78c.tar.bz2
historical-bfae2785546de756f9801e3d5ec8380c0f4aa78c.zip
soundscope visualiser plugin
Diffstat (limited to 'x11-plugins/gkrellmss/gkrellmss-2.3.ebuild')
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.3.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.3.ebuild
new file mode 100644
index 000000000000..36f58d579660
--- /dev/null
+++ b/x11-plugins/gkrellmss/gkrellmss-2.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.3.ebuild,v 1.1 2003/02/12 10:44:27 seemant Exp $
+
+inherit eutils
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
+HOMEPAGE="http://gkrellm.net/gkrellmss/gkrellmss.html"
+SRC_URI="http://gkrellm.net/gkrellmss/${P}.tar.gz"
+
+DEPEND="=app-admin/gkrellm-2*
+ dev-libs/fftw
+ media-sound/esound"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ epatch ${FILESDIR}/gkrellmss-patch-2.3.diff
+}
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="${myconf} enable_nls=1"
+
+ emake ${myconf} || die
+}
+
+src_install () {
+ exeinto /usr/lib/gkrellm2/plugins
+ doexe src/gkrellmss.so
+ dodoc README Changelog Themes
+}