summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-12-08 01:04:12 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-12-08 01:04:12 +0000
commit5f05cc2eb43c3229e0f6ab1635fad2ef3330d890 (patch)
tree0082d92214897b6e741f88862f54089c3b570895 /x11-themes/gnome-themes-extras
parentversion bump and added patch (diff)
downloadhistorical-5f05cc2eb43c3229e0f6ab1635fad2ef3330d890.tar.gz
historical-5f05cc2eb43c3229e0f6ab1635fad2ef3330d890.tar.bz2
historical-5f05cc2eb43c3229e0f6ab1635fad2ef3330d890.zip
version bump and added patch
Diffstat (limited to 'x11-themes/gnome-themes-extras')
-rw-r--r--x11-themes/gnome-themes-extras/Manifest7
-rw-r--r--x11-themes/gnome-themes-extras/files/digest-gnome-themes-extras-0.51
-rw-r--r--x11-themes/gnome-themes-extras/files/gnome-themes-extras-0.5-industrial_uncorrupt.patch45
-rw-r--r--x11-themes/gnome-themes-extras/gnome-themes-extras-0.4.ebuild4
-rw-r--r--x11-themes/gnome-themes-extras/gnome-themes-extras-0.5.ebuild29
5 files changed, 81 insertions, 5 deletions
diff --git a/x11-themes/gnome-themes-extras/Manifest b/x11-themes/gnome-themes-extras/Manifest
index d2f8a67b9016..c13a6274c2d8 100644
--- a/x11-themes/gnome-themes-extras/Manifest
+++ b/x11-themes/gnome-themes-extras/Manifest
@@ -1,10 +1,11 @@
-MD5 aca464927ede91bd548232b2aa16e346 ChangeLog 1052
+MD5 14d77783e83b4fda00caeb4083257c69 ChangeLog 1397
MD5 9c8e3f2eafaf44a1850b3a22fd07721f gnome-themes-extras-0.2.ebuild 575
MD5 82fc100c5e2b84efbd523abf639eceff gnome-themes-extras-0.3.ebuild 576
-MD5 84f9e2aeeee08e3a6a7bfe76b54accee gnome-themes-extras-0.4.ebuild 730
-MD5 39c9f731bcc4247dbfdb05976b6894a5 gnome-themes-extras-0.5.ebuild 740
+MD5 52f7440ce10732da583c851461005f2e gnome-themes-extras-0.4.ebuild 730
+MD5 b05aa32a4aba139859f278f4605e7d30 gnome-themes-extras-0.5.ebuild 816
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 d3d68a408142f4836fe51d430d486302 files/digest-gnome-themes-extras-0.2 77
MD5 9639f91edc8f7c846569cccea17aef7e files/digest-gnome-themes-extras-0.3 77
MD5 969059f1ac05f59431bc3a5959eea303 files/digest-gnome-themes-extras-0.4 77
MD5 623769c489254fc5862e52076e7148f4 files/digest-gnome-themes-extras-0.5 77
+MD5 9ae6a37c4ea5cf1b24e203cc3d520a00 files/gnome-themes-extras-0.5-industrial_uncorrupt.patch 1488
diff --git a/x11-themes/gnome-themes-extras/files/digest-gnome-themes-extras-0.5 b/x11-themes/gnome-themes-extras/files/digest-gnome-themes-extras-0.5
new file mode 100644
index 000000000000..daa9700c6b1b
--- /dev/null
+++ b/x11-themes/gnome-themes-extras/files/digest-gnome-themes-extras-0.5
@@ -0,0 +1 @@
+MD5 8b4d38fad00689131cc1fd2b50612cc8 gnome-themes-extras-0.5.tar.bz2 1891854
diff --git a/x11-themes/gnome-themes-extras/files/gnome-themes-extras-0.5-industrial_uncorrupt.patch b/x11-themes/gnome-themes-extras/files/gnome-themes-extras-0.5-industrial_uncorrupt.patch
new file mode 100644
index 000000000000..66e4cc988af2
--- /dev/null
+++ b/x11-themes/gnome-themes-extras/files/gnome-themes-extras-0.5-industrial_uncorrupt.patch
@@ -0,0 +1,45 @@
+--- industrial_style.c.orig 2003-12-07 22:13:42.000000000 +0100
++++ industrial_style.c 2003-12-07 22:14:13.000000000 +0100
+@@ -1283,9 +1283,6 @@
+ gint height,
+ gboolean fill)
+ {
+- if (shadow_type == GTK_SHADOW_NONE)
+- return;
+-
+ g_return_if_fail (style != NULL);
+ g_return_if_fail (window != NULL);
+
+@@ -1430,7 +1427,7 @@
+ }
+
+ /* Only draw shadow if button is large enough to fit it. */
+- if (width > 18 && height > 18) {
++ if (width > 18 && height > 18 && shadow_type != GTK_SHADOW_NONE) {
+
+ /* Offset shadow if depressed. */
+ if (state_type == GTK_STATE_ACTIVE) {
+@@ -1589,7 +1586,7 @@
+
+ #if 1
+ /* Remove this to add the shadow back for depressed buttons. */
+- if (GTK_WIDGET_STATE (widget) == GTK_STATE_ACTIVE)
++ if (GTK_WIDGET_STATE (widget) == GTK_STATE_ACTIVE || shadow_type == GTK_SHADOW_NONE)
+ return;
+ #endif
+
+@@ -1793,8 +1790,12 @@
+ GdkColor *fg_color = get_color (style, &style->bg[state_type], &style->fg[state_type], STANDARD_BORDER_SHADE);
+ GdkGC *corner_gc = get_gc (style, &style->bg[state_type], fg_color, SHADE_HALF);
+
+- draw_rounded_rect_one_pixel (window, bg_gc, fg_gc, corner_gc,
+- area, x, y, width, height);
++ if(shadow_type == GTK_SHADOW_NONE) {
++ if(bg_gc)
++ gdk_draw_rectangle (window, bg_gc, TRUE, x, y, width, height);
++ } else {
++ draw_rounded_rect_one_pixel (window, bg_gc, fg_gc, corner_gc, area, x, y, width, height);
++ }
+ }
+ }
+
diff --git a/x11-themes/gnome-themes-extras/gnome-themes-extras-0.4.ebuild b/x11-themes/gnome-themes-extras/gnome-themes-extras-0.4.ebuild
index 4885bfd0d705..5ab044d71f76 100644
--- a/x11-themes/gnome-themes-extras/gnome-themes-extras-0.4.ebuild
+++ b/x11-themes/gnome-themes-extras/gnome-themes-extras-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-extras/gnome-themes-extras-0.4.ebuild,v 1.2 2003/10/22 19:56:14 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-extras/gnome-themes-extras-0.4.ebuild,v 1.3 2003/12/08 01:03:59 liquidx Exp $
inherit gnome2
@@ -8,7 +8,7 @@ DESCRIPTION="Additional themes for GNOME 2.2"
HOMEPAGE="http://librsvg.sourceforge.net/theme.php"
SLOT="0"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="x86 ~sparc"
IUSE=""
LICENSE="LGPL-2.1 GPL-2 DSL"
diff --git a/x11-themes/gnome-themes-extras/gnome-themes-extras-0.5.ebuild b/x11-themes/gnome-themes-extras/gnome-themes-extras-0.5.ebuild
new file mode 100644
index 000000000000..9ff143c79124
--- /dev/null
+++ b/x11-themes/gnome-themes-extras/gnome-themes-extras-0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-extras/gnome-themes-extras-0.5.ebuild,v 1.1 2003/12/08 01:03:59 liquidx Exp $
+
+inherit gnome2
+
+DESCRIPTION="Additional themes for GNOME 2.2"
+HOMEPAGE="http://librsvg.sourceforge.net/theme.php"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+LICENSE="LGPL-2.1 GPL-2 DSL"
+
+RDEPEND=">=x11-libs/gtk+-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.23"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS README TODO"
+
+src_unpack() {
+ unpack ${A}
+ sed -e 's:gorilla-default:capplet-icons:' \
+ -i ${S}/Gorilla/gtk-2.0/iconrc.in \
+ -i ${S}/Gorilla/gtk-2.0/iconrc
+ EPATCH_OPTS="-d ${S}/Industrial" epatch ${FILESDIR}/${P}-industrial_uncorrupt.patch
+}