summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/mpich/ChangeLog9
-rw-r--r--sys-cluster/mpich/files/digest-mpich-1.2.41
-rw-r--r--sys-cluster/mpich/mpich-1.2.4.ebuild42
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-cluster/mpich/ChangeLog b/sys-cluster/mpich/ChangeLog
new file mode 100644
index 000000000000..b554898d7140
--- /dev/null
+++ b/sys-cluster/mpich/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-admin/openmosixview
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.1 2002/11/05 15:06:09 tantive Exp $
+
+
+*mpich-1.2.4 (05 Nov 2002)
+
+ 05 Nov 2002; Michael Imhof <tantive@gentoo.org>:
+ Initial release.
diff --git a/sys-cluster/mpich/files/digest-mpich-1.2.4 b/sys-cluster/mpich/files/digest-mpich-1.2.4
new file mode 100644
index 000000000000..3961c7b89b17
--- /dev/null
+++ b/sys-cluster/mpich/files/digest-mpich-1.2.4
@@ -0,0 +1 @@
+MD5 45ab0a0fb35aa155ce9368c475a84e12 mpich-1.2.4.tar.gz 12313304
diff --git a/sys-cluster/mpich/mpich-1.2.4.ebuild b/sys-cluster/mpich/mpich-1.2.4.ebuild
new file mode 100644
index 000000000000..4bd8d0d0eaec
--- /dev/null
+++ b/sys-cluster/mpich/mpich-1.2.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.4.ebuild,v 1.1 2002/11/05 15:06:09 tantive Exp $
+
+S=${WORKDIR}/mpich-${PV}
+DESCRIPTION="MPICH - A portable MPI implementation"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/mpich-${PV}.tar.gz"
+HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich"
+IUSE=""
+
+DEPEND="virtual/glibc"
+RDEPEND="net-misc/openssh"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/romio/util/
+ mv romioinstall.in romioinstall.in-orig
+ sed -e "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in-orig >romioinstall.in
+
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --mandir=/usr/share/man || die
+ make || die
+}
+
+src_install() {
+ dodir /usr/sbin
+ dodir /usr/local/bin
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man --infodir=/usr/share/infoinstall --sysconfdir=/etc/mpich || die
+
+ dodoc COPYING README
+
+}
+