summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/prime/prime-0.7.6.ebuild')
-rw-r--r--app-i18n/prime/prime-0.7.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-i18n/prime/prime-0.7.6.ebuild b/app-i18n/prime/prime-0.7.6.ebuild
new file mode 100644
index 000000000000..92ce03f335af
--- /dev/null
+++ b/app-i18n/prime/prime-0.7.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/prime/prime-0.7.6.ebuild,v 1.1 2004/01/29 16:55:52 usata Exp $
+
+inherit ruby
+
+IUSE="emacs"
+
+MY_P="${P/_pre*/-ss1}"
+MY_P="${P/_rc/-rc}"
+
+DESCRIPTION="PRIME -- Japanese PRedictive Input Method Editor"
+HOMEPAGE="http://taiyaki.org/prime/"
+SRC_URI="http://prime.sourceforge.jp/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="dev-lang/ruby
+ app-dicts/prime-dict
+ >=dev-ruby/sary-ruby-0.5_pre20030507-r1
+ >=dev-libs/suikyo-1.3.0
+ dev-ruby/ruby-progressbar"
+PDEPEND="emacs? ( app-emacs/prime-el )"
+
+EXTRA_ECONF="--with-prime-docdir=/usr/share/doc/${PF}/html
+ --with-rubydir=/usr/lib/ruby/site_ruby"
+
+src_install() {
+
+ einstall || die
+ make DESTDIR=${D} install-etc || die
+
+ erubydoc
+
+}