summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/detox/detox-1.1.0.ebuild')
-rw-r--r--app-misc/detox/detox-1.1.0.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/app-misc/detox/detox-1.1.0.ebuild b/app-misc/detox/detox-1.1.0.ebuild
index 02a0e5ccad1a..ba11e1c07c16 100644
--- a/app-misc/detox/detox-1.1.0.ebuild
+++ b/app-misc/detox/detox-1.1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/detox-1.1.0.ebuild,v 1.1 2005/03/05 21:55:55 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/detox-1.1.0.ebuild,v 1.2 2005/03/06 13:57:51 ciaranm Exp $
+
+inherit eutils
DESCRIPTION="detox safely removes spaces and strange characters from filenames"
HOMEPAGE="http://detox.sourceforge.net/"
@@ -21,17 +23,12 @@ src_unpack() {
unpack ${A}
cd ${S}
- # make DESTDIR installs work
- sed -i -e '/\${INSTALL}/s,\(^.*\)\$,\1${DESTDIR}/$,g' Makefile.in \
- || die "Makefile.in fix 1 failed. That isn't supposed to happen."
+ epatch ${FILESDIR}/${P}-destdir.patch
+ epatch ${FILESDIR}/${P}-parallel_build.patch
}
src_compile() {
econf --with-popt || die "econf failed"
-
- # The lengths I go to to get parallel make to work. Ain't I kind?
- emake -j 1 config_file_l.c
- emake -j 1 config_file_y.h
emake || die "emake failed"
}