summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/sphinx/sphinx-0.9.8_pre1065.ebuild')
-rw-r--r--app-misc/sphinx/sphinx-0.9.8_pre1065.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/sphinx/sphinx-0.9.8_pre1065.ebuild b/app-misc/sphinx/sphinx-0.9.8_pre1065.ebuild
new file mode 100644
index 000000000000..0cb51a4a4586
--- /dev/null
+++ b/app-misc/sphinx/sphinx-0.9.8_pre1065.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.8_pre1065.ebuild,v 1.1 2008/01/24 00:05:47 caleb Exp $
+
+inherit eutils autotools
+
+MY_P=${P/_pre/-svn-r}
+
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/downloads/${MY_P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="mysql postgres debug"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+# epatch "${FILESDIR}"/${P}-fix-sandbox.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with mysql) \
+ $(use_with postgres) \
+ $(use_with debug) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc doc/* example.sql
+ dodir /etc/sphinx
+ insinto /etc/sphinx
+ doins sphinx.conf.dist
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+ dodir /var/run/sphinx
+}
+