summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/math-pari/math-pari-2.010706.ebuild')
-rw-r--r--dev-perl/math-pari/math-pari-2.010706.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-perl/math-pari/math-pari-2.010706.ebuild b/dev-perl/math-pari/math-pari-2.010706.ebuild
index 579d75125316..91d183d01352 100644
--- a/dev-perl/math-pari/math-pari-2.010706.ebuild
+++ b/dev-perl/math-pari/math-pari-2.010706.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010706.ebuild,v 1.4 2006/08/12 21:30:24 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010706.ebuild,v 1.5 2006/08/13 05:54:16 chriswhite Exp $
inherit perl-module eutils
@@ -26,10 +26,13 @@ DEPEND="~sci-mathematics/pari-2.1.7
dev-lang/perl"
RDEPEND="${DEPEND}"
-# Unfortunately the assembly routines math-pari has for SPARC do not appear
-# to be working at current. Perl cannot test math-pari or anything that pulls
-# in the math-pari module as DynaLoader cannot load the resulting .so files
-# math-pari generates. As such, we have to use the generic non-machine
-# specific assembly methods here.
+src_compile() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that pulls
+ # in the math-pari module as DynaLoader cannot load the resulting .so files
+ # math-pari generates. As such, we have to use the generic non-machine
+ # specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
-use sparc && myconf="${myconf} machine=none"
+ perl-module_src_compile
+}