summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-pipeline/django-pipeline-1.3.9.ebuild')
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.9.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.9.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.9.ebuild
index 7625c8f7f224..db6f55b4c140 100644
--- a/dev-python/django-pipeline/django-pipeline-1.3.9.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.9.ebuild,v 1.1 2013/05/17 13:37:03 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.9.ebuild,v 1.2 2013/05/20 16:43:13 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -36,12 +36,13 @@ python_compile() {
python_test() {
export DJANGO_SETTINGS_MODULE="django.conf"
+ export SECRET_KEY='green'
local test
pushd "${BUILD_DIR}"/lib/tests/tests/ > /dev/null || die
- for test in [a-z]*.py
+ for test in test_*.py
do
if ! "${PYTHON}" -c \
- "from django.conf import global_settings;global_settings.SECRET_KEY='green'" ${test}
+ "from django.conf import global_settings;global_settings.SECRET_KEY='$SECRET_KEY'" ${test}
then
die "test ${test} failed under ${EPYTHON}"
else