summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/epydoc/epydoc-1.1.ebuild')
-rw-r--r--dev-python/epydoc/epydoc-1.1.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/dev-python/epydoc/epydoc-1.1.ebuild b/dev-python/epydoc/epydoc-1.1.ebuild
index 9b1f977c936d..b611162f6647 100644
--- a/dev-python/epydoc/epydoc-1.1.ebuild
+++ b/dev-python/epydoc/epydoc-1.1.ebuild
@@ -1,28 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/epydoc/epydoc-1.1.ebuild,v 1.5 2003/06/22 12:15:59 liquidx Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/epydoc/epydoc-1.1.ebuild,v 1.6 2003/08/07 02:33:54 vapier Exp $
inherit distutils
-S=${WORKDIR}/${P}
-DESCRIPTION=" Epydoc is a tool for generating API documentation for Python modules, based on their docstrings."
-SRC_URI="mirror://sourceforge/epydoc/${P}.tar.gz"
+DESCRIPTION="tool for generating API documentation for Python modules, based on their docstrings"
HOMEPAGE="http://epydoc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/epydoc/${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
-RDEPEND="virtual/python"
-DEPEND="$DEPEND"
KEYWORDS="x86"
-IUSE=""
+
+RDEPEND="virtual/python"
src_install() {
- distutils_src_install
+ distutils_src_install
- # copy docs (using cp -r cuz of some sub-dirs)
- cp -r ${S}/doc/* ${D}/usr/share/doc/${P}/
-
- # man-pages
- doman ${S}/man/*
-
+ # copy docs (using cp -r cuz of some sub-dirs)
+ cp -r ${S}/doc/* ${D}/usr/share/doc/${PF}/
+ prepalldocs
+ doman ${S}/man/*
}
-