summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygene/pygene-0.2.1.ebuild')
-rw-r--r--dev-python/pygene/pygene-0.2.1.ebuild35
1 files changed, 19 insertions, 16 deletions
diff --git a/dev-python/pygene/pygene-0.2.1.ebuild b/dev-python/pygene/pygene-0.2.1.ebuild
index 0d05c3e7ab7c..55922c5ae4d3 100644
--- a/dev-python/pygene/pygene-0.2.1.ebuild
+++ b/dev-python/pygene/pygene-0.2.1.ebuild
@@ -1,43 +1,46 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygene/pygene-0.2.1.ebuild,v 1.3 2009/02/15 22:48:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygene/pygene-0.2.1.ebuild,v 1.4 2010/07/08 18:37:19 arfrever Exp $
-NEED_PYTHON=2.4
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="Simple python genetic algorithms programming library"
-SRC_URI="http://www.freenet.org.nz/python/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.freenet.org.nz/python/pygene/"
+SRC_URI="http://www.freenet.org.nz/python/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-LICENSE="GPL-2"
IUSE="doc examples"
+
DEPEND="doc? ( >=dev-python/epydoc-2.1-r2 )"
RDEPEND="examples? ( >=dev-python/pyfltk-1.1.2 )"
DOCS="BUGS CREDITS INSTALL"
src_compile() {
-
distutils_src_compile
- if use doc ; then
- epydoc -n "pygene - Python genetic algorithms" -o "${S}"/doc \
- "${S}"/pygene || die "epydoc failed"
+ if use doc; then
+ einfo "Generation of documentation"
+ epydoc -n "pygene - Python genetic algorithms" -o doc pygene || die "Generation of documentation failed"
fi
-
}
src_install() {
-
distutils_src_install
- use doc && \
- dohtml -r doc/*
+ if use doc; then
+ dohtml -r doc/* || die "Installation of documentation failed"
+ fi
- if use examples ; then
- insinto /usr/share/doc/"${PF}"/examples
- doins demo*.py salesman.gif || die 'doins failed'
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo*.py salesman.gif || die "Installation of examples failed"
fi
}