summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activerecord/activerecord-2.0.2.ebuild')
-rw-r--r--dev-ruby/activerecord/activerecord-2.0.2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/activerecord/activerecord-2.0.2.ebuild b/dev-ruby/activerecord/activerecord-2.0.2.ebuild
new file mode 100644
index 000000000000..9dc08de9d6c9
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.0.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.0.2.ebuild,v 1.1 2007/12/18 07:11:29 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ =dev-ruby/activesupport-2.0.2
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"