summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ffi/ffi-1.0.9.ebuild')
-rw-r--r--dev-ruby/ffi/ffi-1.0.9.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/ffi/ffi-1.0.9.ebuild b/dev-ruby/ffi/ffi-1.0.9.ebuild
new file mode 100644
index 000000000000..38b6ab15a75c
--- /dev/null
+++ b/dev-ruby/ffi/ffi-1.0.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ffi-1.0.9.ebuild,v 1.1 2011/06/05 09:17:28 graaff Exp $
+
+EAPI=4
+
+# jruby → unneeded, this is part of the standard JRuby distribution, and
+# would just install a dummy.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
+HOMEPAGE="http://wiki.github.com/ffi/ffi"
+
+SRC_URI="http://github.com/${PN}/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/${PN}-${PN}-*"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+RDEPEND="${RDEPEND} dev-libs/libffi"
+DEPEND="${DEPEND} dev-libs/libffi"
+
+ruby_add_bdepend dev-ruby/rake-compiler
+
+ruby_add_rdepend "virtual/ruby-threads"
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "compile failed"
+ ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}