summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclxml/tclxml-2.6.ebuild')
-rw-r--r--dev-tcltk/tclxml/tclxml-2.6.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/dev-tcltk/tclxml/tclxml-2.6.ebuild b/dev-tcltk/tclxml/tclxml-2.6.ebuild
index 3e1cb3126f8d..cc673c2f775c 100644
--- a/dev-tcltk/tclxml/tclxml-2.6.ebuild
+++ b/dev-tcltk/tclxml/tclxml-2.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.6.ebuild,v 1.9 2005/04/07 13:56:01 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-2.6.ebuild,v 1.10 2006/06/04 02:30:46 matsuu Exp $
+
+inherit eutils
DESCRIPTION="Pure Tcl implementation of an XML parser."
HOMEPAGE="http://tclxml.sourceforge.net/"
@@ -11,6 +13,14 @@ SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha ~amd64"
DEPEND=">=dev-lang/tcl-8.3.3"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e "s/relid'/relid/" \
+ configure tcl.m4 tclconfig/tcl.m4 expat/configure || die
+}
+
src_compile() {
econf || die
make || die