summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild')
-rw-r--r--games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild b/games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild
new file mode 100644
index 000000000000..9697b628a0f9
--- /dev/null
+++ b/games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.37_pre20041220.ebuild,v 1.1 2004/01/05 03:56:45 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="SNES (Super Nintendo) emulator that uses x86 assembly"
+HOMEPAGE="http://www.zsnes.com/"
+SRC_URI="http://ipher.emuhost.com/files/zsnes/ZSNESS_${PV/*2004}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE="opengl"
+
+RDEPEND="opengl? ( virtual/opengl )
+ virtual/x11
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib
+ media-libs/libpng"
+DEPEND="${RDEPEND}
+ >=dev-lang/nasm-0.98
+ sys-devel/automake
+ sys-devel/autoconf"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ for f in * ; do
+ mv ${f} ${f/zsnes\\\\}
+ done
+ cd src
+ edos2unix config.{guess,sub}
+ aclocal || die "aclocal failed"
+ env WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ # Do NOT introduce custom ${CFLAGS}.
+ # Current choices are the optimal ones
+ cd src
+ egamesconf `use_with opengl` || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/zsnes
+ newman src/linux/zsnes.1 zsnes.6
+ dodoc *.txt linux/*
+ prepgamesdirs
+}