summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/ltris/ltris-1.0.18.ebuild')
-rw-r--r--games-puzzle/ltris/ltris-1.0.18.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/ltris/ltris-1.0.18.ebuild b/games-puzzle/ltris/ltris-1.0.18.ebuild
new file mode 100644
index 000000000000..3dc517b5288d
--- /dev/null
+++ b/games-puzzle/ltris/ltris-1.0.18.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ltris-1.0.18.ebuild,v 1.1 2011/12/21 18:50:20 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="very polished Tetris clone"
+HOMEPAGE="http://lgames.sourceforge.net/index.php?project=LTris"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ newicon icons/ltris48.xpm ${PN}.xpm
+ make_desktop_entry ltris LTris
+ prepgamesdirs
+}