summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kate/kate-4.9.5.ebuild')
-rw-r--r--kde-base/kate/kate-4.9.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/kate/kate-4.9.5.ebuild b/kde-base/kate/kate-4.9.5.ebuild
new file mode 100644
index 000000000000..c0c294fe58f7
--- /dev/null
+++ b/kde-base/kate/kate-4.9.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.9.5.ebuild,v 1.1 2013/01/05 20:18:57 creffett Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kate"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep katepart)
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}