summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kicker/kicker-3.5.4.ebuild')
-rw-r--r--kde-base/kicker/kicker-3.5.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-base/kicker/kicker-3.5.4.ebuild b/kde-base/kicker/kicker-3.5.4.ebuild
new file mode 100644
index 000000000000..a13658dd0e8d
--- /dev/null
+++ b/kde-base/kicker/kicker-3.5.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/kicker-3.5.4.ebuild,v 1.1 2006/07/25 06:03:17 flameeyes Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-02.tar.bz2"
+
+DESCRIPTION="KDE panel housing varous applets"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="xcomposite"
+
+RDEPEND="
+$(deprange $PV $MAXKDEVER kde-base/libkonq)
+$(deprange $PV $MAXKDEVER kde-base/kdebase-data)
+ || ( (
+ x11-libs/libXau
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ ) <virtual/x11-7 )
+ xcomposite? ( || ( x11-libs/libXcomposite <x11-base/xorg-x11-7 ) )"
+
+DEPEND="${RDEPEND}
+ xcomposite? ( || ( x11-proto/compositeproto <x11-base/xorg-x11-7 ) )"
+
+KMCOPYLIB="libkonq libkonq"
+KMEXTRACTONLY="libkonq
+ kdm/kfrontend/themer/"
+KMCOMPILEONLY="kdmlib/"
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}