summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/libkcddb/libkcddb-4.6.2.ebuild')
-rw-r--r--kde-base/libkcddb/libkcddb-4.6.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/libkcddb/libkcddb-4.6.2.ebuild b/kde-base/libkcddb/libkcddb-4.6.2.ebuild
new file mode 100644
index 000000000000..ef3bbe0886c1
--- /dev/null
+++ b/kde-base/libkcddb/libkcddb-4.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcddb/libkcddb-4.6.2.ebuild,v 1.1 2011/04/06 14:19:08 scarabeus Exp $
+
+EAPI=3
+
+KMNAME="kdemultimedia"
+inherit kde4-meta
+
+DESCRIPTION="KDE library for CDDB"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug musicbrainz"
+
+# tests require network access and compare static data with online data
+# bug 280996
+RESTRICT=test
+
+DEPEND="
+ musicbrainz? ( media-libs/musicbrainz:3 )
+"
+RDEPEND="${DEPEND}"
+
+KMSAVELIBS="true"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with musicbrainz MusicBrainz3)
+ )
+
+ kde4-meta_src_configure
+}