summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gimp')
-rw-r--r--media-gfx/gimp/Manifest18
-rw-r--r--media-gfx/gimp/gimp-1.2.3-r3.ebuild22
-rw-r--r--media-gfx/gimp/gimp-1.2.4.ebuild14
-rw-r--r--media-gfx/gimp/gimp-1.2.5.ebuild14
-rw-r--r--media-gfx/gimp/gimp-1.3.17.ebuild8
-rw-r--r--media-gfx/gimp/gimp-1.3.18.ebuild10
-rw-r--r--media-gfx/gimp/gimp-1.3.19.ebuild10
7 files changed, 48 insertions, 48 deletions
diff --git a/media-gfx/gimp/Manifest b/media-gfx/gimp/Manifest
index 5ac0b44072cb..9098a18b2a89 100644
--- a/media-gfx/gimp/Manifest
+++ b/media-gfx/gimp/Manifest
@@ -1,20 +1,20 @@
MD5 f4e5ec69e2d761efb43ac249c4058a37 ChangeLog 8145
-MD5 3ffcb6910a8be02857177f4179725ca8 gimp-1.2.3-r3.ebuild 4717
-MD5 88c91a6b638a0b6fd51b7e32bd2f0f23 gimp-1.2.4.ebuild 3088
-MD5 df9bc36615a041850ff9feaf1d0df2c5 gimp-1.2.5.ebuild 3257
-MD5 789c502d34f4e1a21f1d225da50e5864 gimp-1.3.17.ebuild 2413
-MD5 c767b8534e97decd509fc3d6b0c9f341 gimp-1.3.18.ebuild 2401
-MD5 004d41bd001a83a1f9506b6c51406600 gimp-1.3.19.ebuild 2403
+MD5 d410d062966d05248f9c4251bd81d3af gimp-1.2.3-r3.ebuild 4707
+MD5 74527154777079e96af121051dc3441b gimp-1.3.17.ebuild 2413
+MD5 06e96d6cc8a8dd73b20043a194b716ce gimp-1.3.18.ebuild 2400
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 3d28dd0ccc739e10db388438d4f06dda gimp-1.2.4.ebuild 3086
+MD5 d235271944c1076aa7edb1726b79fecd gimp-1.2.5.ebuild 3253
+MD5 75ad0c3088982ebf00bc3d06d2f47602 gimp-1.3.19.ebuild 2400
MD5 86617fa03849f2ba22c845a31ddf8958 files/digest-gimp-1.2.3-r3 65
-MD5 86551dc2402aaed28ccf3612e8fe7b7a files/digest-gimp-1.2.4 65
+MD5 067de92aa202ecaed5618d0718667dcb files/digest-gimp-1.3.18 66
MD5 662e7b51f4c882429b73dea3263b39de files/digest-gimp-1.2.5 65
MD5 bc0cf9570b3e8a71b95426095b0ca86c files/digest-gimp-1.3.17 66
-MD5 067de92aa202ecaed5618d0718667dcb files/digest-gimp-1.3.18 66
MD5 22953f0155eaf6fb3dda5b1d665eb493 files/digest-gimp-1.3.19 66
MD5 cdda0b1cc179cf75eabb63945efdae0e files/gimp-1.2.3-libgimpi-libtool.diff 1365
MD5 edd3aa0572ed45191d25b99712a875d9 files/gimp-1.2.3-r2-gentoo.diff 427
MD5 edd3aa0572ed45191d25b99712a875d9 files/gimp-1.2.3-r3-gentoo.diff 427
-MD5 edd3aa0572ed45191d25b99712a875d9 files/gimp-1.2.4-gentoo.diff 427
MD5 9696bde4a1b70dd2816d46bed477ebc0 files/gimp.desktop 2404
MD5 f2b58299eceabecfe5df955198c267d6 files/psd_save.c 49151
+MD5 86551dc2402aaed28ccf3612e8fe7b7a files/digest-gimp-1.2.4 65
+MD5 edd3aa0572ed45191d25b99712a875d9 files/gimp-1.2.4-gentoo.diff 427
diff --git a/media-gfx/gimp/gimp-1.2.3-r3.ebuild b/media-gfx/gimp/gimp-1.2.3-r3.ebuild
index 578b30bbcd32..076e6aa7e797 100644
--- a/media-gfx/gimp/gimp-1.2.3-r3.ebuild
+++ b/media-gfx/gimp/gimp-1.2.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.3-r3.ebuild,v 1.10 2003/03/10 12:01:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.3-r3.ebuild,v 1.11 2003/09/06 23:56:38 msterret Exp $
inherit eutils flag-o-matic
@@ -40,20 +40,20 @@ src_unpack() {
die "Not compatible with threaded perl"
fi
unpack ${A}
-
+
cd ${S}/plug-ins/common
# compile with nonstandard psd_save plugin
cp ${FILESDIR}/psd_save.c .
epatch ${FILESDIR}/${PF}-gentoo.diff
cd ${S}
-
+
if [ -f ${ROOT}/usr/share/gettext/config.rpath ] ; then
cp -f ${ROOT}/usr/share/gettext/config.rpath ${S}
else
touch ${S}/config.rpath
chmod 0755 ${S}/config.rpath
fi
-
+
echo ">>> Reconfiguring package..."
export WANT_AUTOMAKE_1_4=1
export WANT_AUTOCONF_2_1=1
@@ -81,7 +81,7 @@ src_unpack() {
src_compile() {
-
+
# Strip out -fomit-frame-pointer for k6's
is-flag "-march=k6-3" && strip-flags "-fomit-frame-pointer"
is-flag "-march=k6-2" && strip-flags "-fomit-frame-pointer"
@@ -122,7 +122,7 @@ src_compile() {
--disable-debug \
${myconf} || die
- if [ -z "`use aalib`" ] ; then
+ if [ -z "`use aalib`" ] ; then
# Horrible automake brokenness
cp plug-ins/common/Makefile plug-ins/common/Makefile.orig
cat plug-ins/common/Makefile.orig | \
@@ -136,7 +136,7 @@ src_compile() {
src_install() {
- local mymake=""
+ local mymake=""
if [ -z "`use aalib`" ] ; then
mymake="LIBAA= AA="
fi
@@ -144,9 +144,9 @@ src_install() {
if [ -z "`use gnome`" ] ; then
mymake="${mymake} HELPBROWSER="
fi
-
+
dodir /usr/lib/gimp/1.2/plug-ins
-
+
einstall \
gimpdatadir=${D}/usr/share/gimp/1.2 \
gimpsysconfdir=${D}/etc/gimp/1.2 \
@@ -168,9 +168,9 @@ src_install() {
insinto /usr/share/applications
doins ${FILESDIR}/gimp.desktop
fi
-
+
preplib /usr
-
+
dodoc AUTHORS COPYING ChangeLog* *MAINTAINERS README* TODO
dodoc docs/*.txt docs/*.ps docs/Wilber* docs/quick_reference.tar.gz
dohtml -r devel-docs
diff --git a/media-gfx/gimp/gimp-1.2.4.ebuild b/media-gfx/gimp/gimp-1.2.4.ebuild
index 59f0852d03bc..c7fab05dae07 100644
--- a/media-gfx/gimp/gimp-1.2.4.ebuild
+++ b/media-gfx/gimp/gimp-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.4.ebuild,v 1.9 2003/08/15 10:11:49 todd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.4.ebuild,v 1.10 2003/09/06 23:56:38 msterret Exp $
inherit eutils flag-o-matic
@@ -65,7 +65,7 @@ src_compile() {
`use_enable doc gtk-doc` \
${myconf} || die
- if [ -z "`use aalib`" ] ; then
+ if [ -z "`use aalib`" ] ; then
# Horrible automake brokenness
cp plug-ins/common/Makefile plug-ins/common/Makefile.orig
cat plug-ins/common/Makefile.orig | \
@@ -79,12 +79,12 @@ src_compile() {
src_install() {
- local mymake=""
+ local mymake=""
use aalib || mymake="LIBAA= AA="
use gnome || mymake="${mymake} HELPBROWSER="
-
+
dodir /usr/lib/gimp/1.2/plug-ins
-
+
einstall \
gimpdatadir=${D}/usr/share/gimp/1.2 \
gimpsysconfdir=${D}/etc/gimp/1.2 \
@@ -109,9 +109,9 @@ src_install() {
insinto /usr/share/applications
doins ${FILESDIR}/gimp.desktop
)
-
+
preplib /usr
-
+
dodoc AUTHORS COPYING ChangeLog* *MAINTAINERS README* TODO
dodoc docs/*.txt docs/*.ps docs/Wilber* docs/quick_reference.tar.gz
}
diff --git a/media-gfx/gimp/gimp-1.2.5.ebuild b/media-gfx/gimp/gimp-1.2.5.ebuild
index a361af14f6f1..d73d377a4dd0 100644
--- a/media-gfx/gimp/gimp-1.2.5.ebuild
+++ b/media-gfx/gimp/gimp-1.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.5.ebuild,v 1.6 2003/08/10 23:39:06 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.5.ebuild,v 1.7 2003/09/06 23:56:38 msterret Exp $
inherit eutils flag-o-matic
@@ -68,7 +68,7 @@ src_compile() {
`use_enable doc gtk-doc` \
${myconf} || die
- if [ -z "`use aalib`" ] ; then
+ if [ -z "`use aalib`" ] ; then
# Horrible automake brokenness
cp plug-ins/common/Makefile plug-ins/common/Makefile.orig
cat plug-ins/common/Makefile.orig | \
@@ -85,14 +85,14 @@ src_compile() {
src_install() {
- local mymake=""
+ local mymake=""
local AA
use aalib || mymake="LIBAA= AA="
use gnome || mymake="${mymake} HELPBROWSER="
-
+
dodir /usr/lib/gimp/1.2/plug-ins
-
+
einstall \
gimpdatadir=${D}/usr/share/gimp/1.2 \
gimpsysconfdir=${D}/etc/gimp/1.2 \
@@ -117,9 +117,9 @@ src_install() {
insinto /usr/share/applications
doins ${FILESDIR}/gimp.desktop
)
-
+
preplib /usr
-
+
dodoc AUTHORS COPYING ChangeLog* *MAINTAINERS README* TODO
dodoc docs/*.txt docs/*.ps docs/Wilber* docs/quick_reference.tar.gz
}
diff --git a/media-gfx/gimp/gimp-1.3.17.ebuild b/media-gfx/gimp/gimp-1.3.17.ebuild
index b17efc7c7ca5..0aeca0219f10 100644
--- a/media-gfx/gimp/gimp-1.3.17.ebuild
+++ b/media-gfx/gimp/gimp-1.3.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.17.ebuild,v 1.2 2003/08/04 08:40:43 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.17.ebuild,v 1.3 2003/09/06 23:56:38 msterret Exp $
IUSE="doc python aalib png jpeg tiff gtkhtml mmx sse X"
@@ -74,10 +74,10 @@ src_compile() {
src_install() {
# workaround portage variable leakage
local AA
-
+
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeL* HACKING INSTALL MAINTAINERS NEWS PLUGIN_MAINTAINERS README* TODO*
-
+
# fix desktop link in the right place
dodir /usr/share/applications
rm ${D}/usr/share/gimp/1.3/misc/gimp-1.3.desktop
@@ -86,5 +86,5 @@ src_install() {
pkg_postinst() {
ewarn "The 1.3 Gimp series have been reslotted to SLOT 2."
- ewarn "To clean up old 1.3 version remove all 1.3 series and recompile."
+ ewarn "To clean up old 1.3 version remove all 1.3 series and recompile."
}
diff --git a/media-gfx/gimp/gimp-1.3.18.ebuild b/media-gfx/gimp/gimp-1.3.18.ebuild
index aad054e9ba57..a192fc16ff72 100644
--- a/media-gfx/gimp/gimp-1.3.18.ebuild
+++ b/media-gfx/gimp/gimp-1.3.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.18.ebuild,v 1.2 2003/08/28 19:34:08 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.18.ebuild,v 1.3 2003/09/06 23:56:38 msterret Exp $
IUSE="doc python aalib png jpeg tiff gtkhtml mmx sse X"
@@ -23,7 +23,7 @@ RDEPEND=">=x11-libs/gtk+-2.2
gtkhtml? ( =gnome-extra/libgtkhtml-2* )
png? ( >=media-libs/libpng-1.2.1 )
- jpeg? ( >=media-libs/jpeg-6b-r2
+ jpeg? ( >=media-libs/jpeg-6b-r2
media-libs/libexif )
tiff? ( >=media-libs/tiff-3.5.7 )
>=media-libs/libart_lgpl-2.3.8-r1
@@ -75,10 +75,10 @@ src_compile() {
src_install() {
# workaround portage variable leakage
local AA
-
+
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeL* HACKING INSTALL MAINTAINERS NEWS PLUGIN_MAINTAINERS README* TODO*
-
+
# fix desktop link in the right place
dodir /usr/share/applications
rm ${D}/usr/share/gimp/1.3/misc/gimp-1.3.desktop
@@ -87,5 +87,5 @@ src_install() {
pkg_postinst() {
ewarn "The 1.3 Gimp series have been reslotted to SLOT 2."
- ewarn "To clean up old 1.3 version remove all 1.3 series and recompile."
+ ewarn "To clean up old 1.3 version remove all 1.3 series and recompile."
}
diff --git a/media-gfx/gimp/gimp-1.3.19.ebuild b/media-gfx/gimp/gimp-1.3.19.ebuild
index 66c0b1d05d4d..d8ad1bb7f257 100644
--- a/media-gfx/gimp/gimp-1.3.19.ebuild
+++ b/media-gfx/gimp/gimp-1.3.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.19.ebuild,v 1.1 2003/08/30 18:14:43 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.19.ebuild,v 1.2 2003/09/06 23:56:38 msterret Exp $
IUSE="doc python aalib png jpeg tiff gtkhtml mmx sse X"
@@ -23,7 +23,7 @@ RDEPEND=">=x11-libs/gtk+-2.2
gtkhtml? ( =gnome-extra/libgtkhtml-2* )
png? ( >=media-libs/libpng-1.2.1 )
- jpeg? ( >=media-libs/jpeg-6b-r2
+ jpeg? ( >=media-libs/jpeg-6b-r2
media-libs/libexif )
tiff? ( >=media-libs/tiff-3.5.7 )
>=media-libs/libart_lgpl-2.3.8-r1
@@ -75,10 +75,10 @@ src_compile() {
src_install() {
# workaround portage variable leakage
local AA
-
+
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeL* HACKING INSTALL MAINTAINERS NEWS PLUGIN_MAINTAINERS README* TODO*
-
+
# fix desktop link in the right place
dodir /usr/share/applications
rm ${D}/usr/share/gimp/1.3/misc/gimp-1.3.desktop
@@ -87,5 +87,5 @@ src_install() {
pkg_postinst() {
ewarn "The 1.3 Gimp series have been reslotted to SLOT 2."
- ewarn "To clean up old 1.3 version remove all 1.3 series and recompile."
+ ewarn "To clean up old 1.3 version remove all 1.3 series and recompile."
}