summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/amap/amap-4.8.ebuild')
-rw-r--r--net-analyzer/amap/amap-4.8.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/net-analyzer/amap/amap-4.8.ebuild b/net-analyzer/amap/amap-4.8.ebuild
deleted file mode 100644
index 3af3e06d5d71..000000000000
--- a/net-analyzer/amap/amap-4.8.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/amap/amap-4.8.ebuild,v 1.2 2005/04/07 20:54:35 vanquirius Exp $
-
-inherit eutils
-
-DESCRIPTION="A network scanning tool for pentesters"
-HOMEPAGE="http://www.thc.org/thc-amap/"
-SRC_URI="http://www.thc.org/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="ssl"
-
-DEPEND="virtual/libc
- dev-libs/libpcre
- ssl? ( >=dev-libs/openssl-0.9.6j )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i \
- -e 's:/usr/local:/usr:' \
- -e '/AMAP_APPDEF_PATH/s:/etc:/share/amap:' \
- amap.h || die "sed amap.h failed"
-
- rm -rf pcre-3.9
- epatch ${FILESDIR}/${PV}-system-pcre.patch
- epatch ${FILESDIR}/${P}-fix-icky-lvalue-casts.diff
-}
-
-src_compile() {
- # has it's own stupid custom configure script
- ./configure || die "configure failed"
- sed -i \
- -e '/^XDEFINES=/s:=.*:=:' \
- -e '/^XLIBS=/s:=.*:=:' \
- -e '/^XLIBPATHS/s:=.*:=:' \
- -e '/^XIPATHS=/s:=.*:=:' \
- Makefile || die "pruning vars"
- if use ssl ; then
- sed -i \
- -e '/^XDEFINES=/s:=:=-DOPENSSL:' \
- -e '/^XLIBS=/s:=:=-lcrypto -lssl:' \
- Makefile || die "adding ssl"
- fi
- emake OPT="${CFLAGS}" || die "emake failed"
-}
-
-src_install() {
- dobin amap amapcrap || die "dobin failed"
- insinto /usr/share/amap
- doins appdefs.* || die "doins failed"
-
- doman ${PN}.1
- dodoc README TODO CHANGES
-}