summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild')
-rw-r--r--sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild b/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
index d4e474ea8f57..4cea0788ad6a 100644
--- a/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
+++ b/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild,v 1.10 2006/10/29 21:11:56 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-1.0.1-r1.ebuild,v 1.11 2008/01/10 10:45:08 calchan Exp $
inherit eutils
@@ -13,24 +13,26 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc sparc x86"
-DEPEND="=x11-libs/gtk+-2*
+RDEPEND="=x11-libs/gtk+-2*
png? ( media-libs/libpng )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
src_compile() {
local confOptions
confOptions='--enable-gtk2'
- use xinerama && epatch ${FILESDIR}/${PN}-1.0.0-Xinerama.patch
+ use xinerama && epatch "${FILESDIR}/${PN}-1.0.0-Xinerama.patch"
use png || confOptions="$confOptions --disable-exportpng"
- epatch ${FILESDIR}/${PN}-1.0.0-gcc-4.10.patch
+ epatch "${FILESDIR}/${PN}-1.0.0-gcc-4.10.patch"
econf $confOptions || die
emake || die
}
src_install () {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
if use doc; then
cd doc
dodoc sources.txt