summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/twelf/twelf-1.7.1.ebuild')
-rw-r--r--sci-mathematics/twelf/twelf-1.7.1.ebuild60
1 files changed, 31 insertions, 29 deletions
diff --git a/sci-mathematics/twelf/twelf-1.7.1.ebuild b/sci-mathematics/twelf/twelf-1.7.1.ebuild
index 827219ba8459..8e823c0417de 100644
--- a/sci-mathematics/twelf/twelf-1.7.1.ebuild
+++ b/sci-mathematics/twelf/twelf-1.7.1.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/twelf/twelf-1.7.1.ebuild,v 1.3 2014/01/06 14:26:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/twelf/twelf-1.7.1.ebuild,v 1.4 2014/01/15 08:07:10 gienah Exp $
-EAPI=5
+EAPI="5"
-inherit elisp-common eutils multilib
+inherit base elisp-common multilib
MY_PN="${PN}-src"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Implementation of the logical framework LF"
+DESCRIPTION="Twelf is an implementation of the logical framework LF."
HOMEPAGE="http://twelf.org/"
SRC_URI="http://twelf.plparty.org/releases/${MY_P}.tar.gz"
@@ -17,59 +17,60 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
LICENSE="BSD-2"
IUSE="doc emacs examples"
-
# tests reference non-existing directory TEST
RESTRICT="test"
-RDEPEND="
- dev-lang/mlton
- doc? ( virtual/latex-base )
- emacs? ( virtual/emacs )"
+RDEPEND="dev-lang/mlton
+ doc? (
+ virtual/latex-base
+ )
+ emacs? (
+ virtual/emacs
+ )"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}
SITEFILE=50${PN}-gentoo.el
-PATCHES=(
- "${FILESDIR}"/${PN}-1.7.1-doc-guide-twelf-dot-texi.patch
- "${FILESDIR}"/${PN}-1.7.1-doc-guide-Makefile.patch
- "${FILESDIR}"/${PN}-1.7.1-emacs-twelf.patch
- "${FILESDIR}"/${PN}-1.7.1-emacs-twelf-init.patch
- "${FILESDIR}"/${PN}-1.7.1-Makefile.patch
- )
+PATCHES=("${FILESDIR}/${PN}-1.7.1-doc-guide-twelf-dot-texi.patch"
+ "${FILESDIR}/${PN}-1.7.1-doc-guide-Makefile.patch"
+ "${FILESDIR}/${PN}-1.7.1-emacs-twelf.patch"
+ "${FILESDIR}/${PN}-1.7.1-emacs-twelf-init.patch"
+ "${FILESDIR}/${PN}-1.7.1-Makefile.patch"
+ "${FILESDIR}/${PN}-1.7.1-mlton-mlb.patch")
src_prepare() {
- epatch ${PATCHES[@]}
- sed \
- -e "s@/usr/bin@${ROOT}usr/bin@g" \
+ base_src_prepare
+ sed -e "s@/usr/bin@${ROOT}usr/bin@g" \
-e "s@/usr/share@${ROOT}usr/share@" \
-i "${S}"/emacs/twelf-init.el \
|| die "Could not set ROOT in ${S}/emacs/twelf-init.el"
}
src_compile() {
- emake mlton CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake mlton CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS} -fno-PIE"
if use emacs ; then
- pushd "${S}/emacs" > /dev/null || die "Could change directory to emacs"
+ pushd "${S}/emacs" || die "Could change directory to emacs"
elisp-compile \
auc-menu.el \
twelf-font.el \
twelf-init.el \
twelf.el \
|| die "emacs elisp compile failed"
- popd > /dev/null
+ popd
fi
if use doc; then
- pushd doc/guide > /dev/null || die
+ pushd doc/guide
emake all
- popd > /dev/null
+ popd
fi
}
ins_example_dir() {
+ dodir "/usr/share/${PN}/examples/${1}"
insinto "/usr/share/${PN}/examples/${1}"
- pushd "${S}/${1}" > /dev/null || die
+ pushd "${S}/${1}"
doins -r *
popd
}
@@ -85,7 +86,8 @@ src_install() {
ins_example_dir examples-clp
ins_example_dir examples-delphin
fi
- dobin bin/twelf-server
+ exeinto /usr/bin
+ doexe bin/twelf-server
dohtml doc/html/index.html
doinfo doc/guide/twelf.info
dodoc doc/guide/twelf.dvi doc/guide/twelf.ps doc/guide/twelf.pdf
@@ -95,9 +97,9 @@ src_install() {
pkg_postinst() {
if use emacs; then
elisp-site-regen
- elog "For twelf emacs, add this line to ~/.emacs"
- echo ""
- elog '(load (concat twelf-root "/twelf-init.el"))'
+ ewarn "For twelf emacs, add this line to ~/.emacs"
+ ewarn ""
+ ewarn '(load (concat twelf-root "/twelf-init.el"))'
fi
}