summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/cromwell/files')
-rw-r--r--sys-boot/cromwell/files/cromwell-2.40-gcc-3.4.patch82
-rw-r--r--sys-boot/cromwell/files/digest-cromwell-2.311
-rw-r--r--sys-boot/cromwell/files/digest-cromwell-2.40-r11
3 files changed, 83 insertions, 1 deletions
diff --git a/sys-boot/cromwell/files/cromwell-2.40-gcc-3.4.patch b/sys-boot/cromwell/files/cromwell-2.40-gcc-3.4.patch
new file mode 100644
index 000000000000..7c2eca631a86
--- /dev/null
+++ b/sys-boot/cromwell/files/cromwell-2.40-gcc-3.4.patch
@@ -0,0 +1,82 @@
+diff -uNr cromwell-2.40/Makefile cromwell-2.40.patched/Makefile
+--- cromwell-2.40/Makefile 2004-12-02 21:09:50.000000000 +0000
++++ cromwell-2.40.patched/Makefile 2005-09-15 22:51:04.000000000 +0000
+@@ -10,7 +10,7 @@
+ -I$(TOPDIR)/startuploader -I$(TOPDIR)/drivers/cpu \
+ -I$(TOPDIR)/lib/jpeg/
+
+-CFLAGS = -O2 -mcpu=pentium -Werror $(INCLUDE) -Wstrict-prototypes -fomit-frame-pointer -pipe
++CFLAGS = -O2 -mcpu=pentium -Werror $(INCLUDE) -Wstrict-prototypes -fomit-frame-pointer -pipe
+
+ # add the option for gcc 3.3 only
+ ifeq ($(GCC_3.3), 1)
+diff -uNr cromwell-2.40/boot_rom/bootrom.ld cromwell-2.40.patched/boot_rom/bootrom.ld
+--- cromwell-2.40/boot_rom/bootrom.ld 2003-09-08 11:04:06.000000000 +0000
++++ cromwell-2.40.patched/boot_rom/bootrom.ld 2005-09-15 22:54:24.000000000 +0000
+@@ -45,6 +45,7 @@
+ .rodata ( RAM_CODE + SIZEOF(.text) + SIZEOF(.data) ) : AT ( SIZEOF(.low_rom) + SIZEOF(.text) + SIZEOF(.data)) {
+ *(.rodata);
+ *(.rodata.str1.1);
++ *(.rodata.str1.4);
+ *(.rodata.str1.32);
+ *(.rodata.cst4);
+ *(.rodata.cst8);
+diff -uNr cromwell-2.40/fs/grub/fsys_reiserfs.c cromwell-2.40.patched/fs/grub/fsys_reiserfs.c
+--- cromwell-2.40/fs/grub/fsys_reiserfs.c 2004-06-06 14:50:43.000000000 +0000
++++ cromwell-2.40.patched/fs/grub/fsys_reiserfs.c 2005-09-15 22:53:35.000000000 +0000
+@@ -367,7 +367,7 @@
+
+
+ static __inline__ unsigned long
+-log2 (unsigned long word)
++reiser_log2 (unsigned long word)
+ {
+ __asm__ ("bsfl %1,%0"
+ : "=r" (word)
+@@ -609,7 +609,7 @@
+
+ INFO->version = super.s_version;
+ INFO->blocksize = super.s_blocksize;
+- INFO->fullblocksize_shift = log2 (super.s_blocksize);
++ INFO->fullblocksize_shift = reiser_log2 (super.s_blocksize);
+ INFO->blocksize_shift = INFO->fullblocksize_shift - SECTOR_BITS;
+ INFO->cached_slots =
+ (FSYSREISER_CACHE_SIZE >> INFO->fullblocksize_shift) - 1;
+diff -uNr cromwell-2.40/lib/gzip/misc.c cromwell-2.40.patched/lib/gzip/misc.c
+--- cromwell-2.40/lib/gzip/misc.c 2004-06-06 14:27:26.000000000 +0000
++++ cromwell-2.40.patched/lib/gzip/misc.c 2005-09-15 22:52:55.000000000 +0000
+@@ -29,8 +29,6 @@
+ *
+ * Incomprehensible are the ways of bootloaders.
+ */
+-static void* memset(void *, int, size_t);
+-static void* memcpy(void *, __const void *, size_t);
+ #define memzero(s, n) memset ((s), 0, (n))
+
+ typedef unsigned char uch;
+@@ -138,25 +136,6 @@
+ free_mem_ptr = (long) *ptr;
+ }
+
+-static void* memset(void* s, int c, size_t n)
+-{
+- int i;
+- char *ss = (char*)s;
+-
+- for (i=0;i<n;i++) ss[i] = c;
+- return s;
+-}
+-
+-static void* memcpy(void* __dest, __const void* __src,
+- size_t __n)
+-{
+- int i;
+- char *d = (char *)__dest, *s = (char *)__src;
+-
+- for (i=0;i<__n;i++) d[i] = s[i];
+- return __dest;
+-}
+-
+ /* ===========================================================================
+ * Fill the input buffer. This is called only when the buffer is empty
+ * and at least one byte is really needed.
diff --git a/sys-boot/cromwell/files/digest-cromwell-2.31 b/sys-boot/cromwell/files/digest-cromwell-2.31
deleted file mode 100644
index e42a9bc76e10..000000000000
--- a/sys-boot/cromwell/files/digest-cromwell-2.31
+++ /dev/null
@@ -1 +0,0 @@
-MD5 04e3b9fd38fe6f831cab5b01ddc3a039 cromwell-2.31.tar.bz2 2866836
diff --git a/sys-boot/cromwell/files/digest-cromwell-2.40-r1 b/sys-boot/cromwell/files/digest-cromwell-2.40-r1
new file mode 100644
index 000000000000..d7e7427b39b7
--- /dev/null
+++ b/sys-boot/cromwell/files/digest-cromwell-2.40-r1
@@ -0,0 +1 @@
+MD5 a6c9789cfa07f52de826c12681bbd595 cromwell-2.40.tar.bz2 943015