summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog12
-rw-r--r--sys-boot/grub/Manifest16
-rw-r--r--sys-boot/grub/files/digest-grub-0.973
-rw-r--r--sys-boot/grub/grub-0.97.ebuild156
4 files changed, 179 insertions, 8 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 9abdecd78cd4..8e5a7f029674 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.50 2005/08/03 03:09:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.51 2005/08/20 00:03:24 vapier Exp $
+
+*grub-0.97 (20 Aug 2005)
+
+ 20 Aug 2005; Mike Frysinger <vapier@gentoo.org> grub-0.96-r1.ebuild,
+ grub-0.96-r2.ebuild, grub-0.96-r3.ebuild, +grub-0.97.ebuild:
+ Version bump #91959 by R Hill.
+
+ 20 Aug 2005; Mike Frysinger <vapier@gentoo.org> grub-0.96-r1.ebuild,
+ grub-0.96-r2.ebuild, grub-0.96-r3.ebuild:
+ Add support for USE=custom-cflags #72196 by basic.
*grub-0.96-r3 (03 Aug 2005)
diff --git a/sys-boot/grub/Manifest b/sys-boot/grub/Manifest
index 8f037e98203c..e1a0fadd578b 100644
--- a/sys-boot/grub/Manifest
+++ b/sys-boot/grub/Manifest
@@ -2,21 +2,23 @@
Hash: SHA1
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 0d0237e5ae0c9763cb910716bcbaf00f grub-0.96-r2.ebuild 4552
-MD5 49ae7636425891125ae6cb623a4d6570 grub-0.96-r1.ebuild 4699
-MD5 13da04f31e144cb6235533f9bc93fd98 grub-0.96-r3.ebuild 4533
+MD5 70d277c51cf834fc480f28e631960cf6 grub-0.96-r2.ebuild 4588
+MD5 6a3fa6901a3a5d3e8a2435bc70b11051 grub-0.96-r1.ebuild 4733
+MD5 b47bf0819ddd6057262dbff2ee1a1d5a grub-0.96-r3.ebuild 4568
MD5 1eef54e9c246858e8998857f8ca77e22 grub-0.94-r1.ebuild 3519
+MD5 f0a2b3429a6fe02a7ad675a392464a8a grub-0.97.ebuild 4484
MD5 c8d30bf5c47b6d9cb935d2adb12a9ac9 grub-0.92-r1.ebuild 2629
-MD5 98a644fce6f7b8cf796fe6a79c527b6b ChangeLog 15313
+MD5 60953a0178bea28f654ff25560f17947 ChangeLog 15676
MD5 97d88870847fafcf5fe4162f6d273e74 files/digest-grub-0.96-r2 193
MD5 c5c746f1feb71d47fb2f5481590b83df files/digest-grub-0.94-r1 190
+MD5 80b2642d044b2ad2983d3925c4531952 files/digest-grub-0.97 191
MD5 a098fd63c2d2748ecbbfe53aae07ed79 files/digest-grub-0.96-r1 193
MD5 9b6b79b2fbed61b893a1333b4f0e62c6 files/digest-grub-0.96-r3 191
MD5 5695c7ea410b6913901208938e05b1ad files/digest-grub-0.92-r1 190
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFC9sUhgIKl8Uu19MoRAoRyAJsETQ+1q953GXPzlcVB+LS94kMqYwCbBDyt
-ar8AM+jh5pTFsFcDdMwD/rY=
-=MdJZ
+iD8DBQFDBnNrgIKl8Uu19MoRAkEIAJ9ABJt8otynVFOJH9OoiPeuOs0xAQCdE7F2
+txcgVBC0b4l2ufLM105PrDg=
+=ovDA
-----END PGP SIGNATURE-----
diff --git a/sys-boot/grub/files/digest-grub-0.97 b/sys-boot/grub/files/digest-grub-0.97
new file mode 100644
index 000000000000..70f5f6ade643
--- /dev/null
+++ b/sys-boot/grub/files/digest-grub-0.97
@@ -0,0 +1,3 @@
+MD5 cd3f3eb54446be6003156158d51f4884 grub-0.97.tar.gz 971783
+MD5 cdd6c89d48982ecd544c0b4774755afd splash.xpm.gz 33856
+MD5 5e6d0bb61fd731753493c1ec39375073 grub-0.97-patches-1.0.tar.bz2 46259
diff --git a/sys-boot/grub/grub-0.97.ebuild b/sys-boot/grub/grub-0.97.ebuild
new file mode 100644
index 000000000000..0a75510d9c61
--- /dev/null
+++ b/sys-boot/grub/grub-0.97.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97.ebuild,v 1.1 2005/08/20 00:03:24 vapier Exp $
+
+inherit mount-boot eutils flag-o-matic toolchain-funcs
+
+PATCHVER=1.0
+DESCRIPTION="GNU GRUB boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/splash.xpm.gz
+ mirror://gentoo/${P}-patches-${PATCHVER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static netboot custom-cflags"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r5"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.7
+ >=sys-devel/autoconf-2.5"
+PROVIDE="virtual/bootloader"
+
+pkg_setup() {
+ if use amd64 ; then
+ if ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "If you are on amd64, make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit objects!"
+ fi
+
+ ABI_ALLOW="x86"
+ ABI="x86"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if [[ -n ${PATCHVER} ]] ; then
+ EPATCH_SUFFIX="patch"
+ epatch "${WORKDIR}"/patch
+
+ # a bunch of patches apply to raw autotool files
+ autoconf || die "autoconf failed"
+ aclocal || die "aclocal failed"
+ automake || die "automake failed"
+ fi
+}
+
+src_compile() {
+ unset BLOCK_SIZE #73499
+
+ ### i686-specific code in the boot loader is a bad idea; disabling to ensure
+ ### at least some compatibility if the hard drive is moved to an older or
+ ### incompatible system.
+
+ # grub-0.95 added -fno-stack-protector detection, to disable ssp for stage2,
+ # but the objcopy's (faulty) test fails if -fstack-protector is default.
+ # create a cache telling configure that objcopy is ok, and add -C to econf
+ # to make use of the cache.
+ #
+ # CFLAGS has to be undefined running econf, else -fno-stack-protector detection fails.
+ # STAGE2_CFLAGS is not allowed to be used on emake command-line, it overwrites
+ # -fno-stack-protector detected by configure, removed from netboot's emake.
+ use custom-cflags || unset CFLAGS
+
+ export grub_cv_prog_objcopy_absolute=yes #79734
+ use static && append-ldflags -static
+
+ # build the net-bootable grub first, but only if "netboot" is set
+ if use netboot ; then
+ econf \
+ --libdir=/lib \
+ --datadir=/usr/lib/grub \
+ --exec-prefix=/ \
+ --disable-auto-linux-mem-opt \
+ --enable-diskless \
+ --enable-{3c{5{03,07,09,29,95},90x},cs89x0,davicom,depca,eepro{,100}} \
+ --enable-{epic100,exos205,ni5210,lance,ne2100,ni{50,65}10,natsemi} \
+ --enable-{ne,ns8390,wd,otulip,rtl8139,sis900,sk-g16,smc9000,tiara} \
+ --enable-{tulip,via-rhine,w89c840} || die "netboot econf failed"
+
+ emake w89c840_o_CFLAGS="-O" || die "making netboot stuff"
+
+ mv -f stage2/{nbgrub,pxegrub} "${S}"/
+ mv -f stage2/stage2 stage2/stage2.netboot
+
+ make clean || die "make clean failed"
+ fi
+
+ # Now build the regular grub
+ # Note that FFS and UFS2 support are broken for now - stage1_5 files too big
+ econf \
+ --libdir=/lib \
+ --datadir=/usr/lib/grub \
+ --exec-prefix=/ \
+ --disable-auto-linux-mem-opt || die "econf failed"
+ emake || die "making regular stuff"
+}
+
+src_test() {
+ # non-default block size also give false pass/fails.
+ unset BLOCK_SIZE
+ make check || die "make check failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ if use netboot ; then
+ exeinto /usr/lib/grub
+ doexe nbgrub pxegrub stage2/stage2.netboot
+ fi
+
+ insinto /boot/grub
+ doins "${DISTDIR}"/splash.xpm.gz
+ newins docs/menu.lst grub.conf.sample
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+ newdoc docs/menu.lst grub.conf.sample
+
+ docinto gentoo
+ dodoc ${PATCHDIR}/README*
+}
+
+pkg_postinst() {
+ [[ ${ROOT} != "/" ]] && return 0
+
+ # change menu.lst to grub.conf
+ if [[ ! -e /boot/grub/grub.conf && -e /boot/grub/menu.lst ]] ; then
+ mv -f /boot/grub/menu.lst /boot/grub/grub.conf
+ ewarn
+ ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
+ ewarn
+ fi
+ einfo "Linking from new grub.conf name to menu.lst"
+ [[ ! -e /boot/grub/menu.lst ]] && ln -snf grub.conf /boot/grub/menu.lst
+
+ [[ -e /boot/grub/stage2 ]] && mv /boot/grub/stage2{,.old}
+
+ einfo "Copying files from /lib/grub and /usr/lib/grub to /boot"
+ for x in /lib/grub/*/* /usr/lib/grub/*/* ; do
+ [[ -f ${x} ]] && cp -p ${x} /boot/grub
+ done
+
+ [[ -e /boot/grub/grub.conf ]] \
+ && /sbin/grub \
+ --batch \
+ --device-map=/boot/grub/device.map \
+ < /boot/grub/grub.conf > /dev/null 2>&1
+}