summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/arcload/ChangeLog7
-rw-r--r--sys-boot/arcload/Manifest4
-rw-r--r--sys-boot/arcload/arcload-0.43.ebuild69
-rw-r--r--sys-boot/arcload/files/digest-arcload-0.431
4 files changed, 79 insertions, 2 deletions
diff --git a/sys-boot/arcload/ChangeLog b/sys-boot/arcload/ChangeLog
index 907a63a73c2b..c3a16743ad50 100644
--- a/sys-boot/arcload/ChangeLog
+++ b/sys-boot/arcload/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/arcload
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcload/ChangeLog,v 1.1 2005/06/12 05:39:03 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcload/ChangeLog,v 1.2 2005/09/11 01:58:09 kumba Exp $
+
+*arcload-0.43 (11 Sep 2005)
+
+ 11 Sep 2005; Joshua Kinard <kumba@gentoo.org> +arcload-0.43.ebuild:
+ New version of arcload, the ultimate SGI system bootloader.
*arcload-0.41 (12 Jun 2005)
diff --git a/sys-boot/arcload/Manifest b/sys-boot/arcload/Manifest
index 3f73ad68933e..15e352fe3d45 100644
--- a/sys-boot/arcload/Manifest
+++ b/sys-boot/arcload/Manifest
@@ -1,4 +1,6 @@
MD5 fb6f9d40d2ded3c067ac1eefaf219a55 arcload-0.41.ebuild 2191
MD5 58a9ae7662a7e557b27a74c70106c08d metadata.xml 366
-MD5 1d046fcfc167cd31f8b3d49bd499ffd7 ChangeLog 483
+MD5 95d0a3b86aadfed04ba818b7f6072462 ChangeLog 645
+MD5 7281132ec00607d4eb227d4e61fb4573 arcload-0.43.ebuild 2284
MD5 15044a63205fe66a9f42ccf799b328fe files/digest-arcload-0.41 64
+MD5 a95a426a82a8a6ad6249e843a4fcedff files/digest-arcload-0.43 64
diff --git a/sys-boot/arcload/arcload-0.43.ebuild b/sys-boot/arcload/arcload-0.43.ebuild
new file mode 100644
index 000000000000..3b1d26c7f4c6
--- /dev/null
+++ b/sys-boot/arcload/arcload-0.43.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/arcload/arcload-0.43.ebuild,v 1.1 2005/09/11 01:58:09 kumba Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="ARCLoad - SGI Multi-bootloader. Able to bootload many different SGI Systems."
+HOMEPAGE="http://www.linux-mips.org/wiki/index.php/ARCLoad"
+SRC_URI="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/${P}.tar.bz2"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+DEPEND="sys-boot/dvhtool"
+RESTRICT="nostrip"
+
+
+pkg_setup() {
+ # See if we're on a cobalt system
+ if [ "${PROFILE_ARCH}" = "cobalt" ]; then
+ echo -e ""
+ eerror "This package is only intended for SGI systems. It will not work on any"
+ eerror "other types of MIPS-based systems or any other architectures"
+ echo -e ""
+ die
+ fi
+}
+
+src_compile() {
+ echo -e ""
+ einfo ">>> Building 32-bit version (sashARCS) for IP22/IP32 ..."
+ cd ${S}
+ make MODE=M32 clean || die
+ make CC=$(tc-getCC) LD=$(tc-getLD) MODE=M32 || die
+ cp ${S}/arcload.ecoff ${WORKDIR}/sashARCS
+
+ echo -e ""
+ einfo ">>> Building 64-bit version (sash64) for IP27/IP28/IP30 ..."
+ make MODE=M64 clean || die
+ make CC=$(tc-getCC) LD=$(tc-getLD) MODE=M64 || die
+ cp ${S}/arcload ${WORKDIR}/sash64
+}
+
+src_install() {
+ cd ${S}
+ dodir /usr/lib/arcload
+ cp ${WORKDIR}/sashARCS ${D}/usr/lib/arcload
+ cp ${WORKDIR}/sash64 ${D}/usr/lib/arcload
+ cp ${S}/arc.cf-bootcd ${D}/usr/lib/arcload/arc-bootcd.cf
+ cp ${S}/arc.cf-octane ${D}/usr/lib/arcload/arc-octane.cf
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "ARCLoad binaries copied to: /usr/lib/arcload"
+ echo -e ""
+ einfo "Use of ARCLoad is relatively easy:"
+ einfo "\t1) Determine which version you need"
+ einfo "\t\tA) sashARCS for IP22/IP32"
+ einfo "\t\tB) sash64 for IP27/IP28/IP30"
+ einfo "\t2) Copy that to the volume header using 'dvhtool'"
+ einfo "\t3) Edit /usr/lib/arcload/arc-*.cf to fit your specific system"
+ einfo "\t (See ${HOMEPAGE} for"
+ einfo "\t an explanation of the format of the config file)"
+ einfo "\t4) Copy the config file to the volume header with 'dvhtool' (make sure it is copied as 'arc.cf')"
+ einfo "\t5) Copy any kernels to the volume header that you want to be bootable"
+ einfo "\t6) Reboot, and enjoy!"
+ echo -e ""
+}
diff --git a/sys-boot/arcload/files/digest-arcload-0.43 b/sys-boot/arcload/files/digest-arcload-0.43
new file mode 100644
index 000000000000..3856b419b4a9
--- /dev/null
+++ b/sys-boot/arcload/files/digest-arcload-0.43
@@ -0,0 +1 @@
+MD5 c57072225b381f8a6bd59a421e815761 arcload-0.43.tar.bz2 22419