summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog8
-rw-r--r--sys-boot/grub/Manifest18
-rw-r--r--sys-boot/grub/grub-0.94-r1.ebuild4
-rw-r--r--sys-boot/grub/grub-0.96-r1.ebuild4
-rw-r--r--sys-boot/grub/grub-0.96-r2.ebuild4
-rw-r--r--sys-boot/grub/grub-0.96-r3.ebuild4
-rw-r--r--sys-boot/grub/grub-0.97.ebuild6
7 files changed, 27 insertions, 21 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 8e5a7f029674..d88aec2652d8 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.51 2005/08/20 00:03:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.52 2005/08/21 02:24:04 vapier Exp $
+
+ 21 Aug 2005; Mike Frysinger <vapier@gentoo.org> grub-0.94-r1.ebuild,
+ grub-0.96-r1.ebuild, grub-0.96-r2.ebuild, grub-0.96-r3.ebuild,
+ grub-0.97.ebuild:
+ Make sure netboot files are installed into /usr/lib/grub/${CHOST}/ so the
+ pkg_postinst step works #103084 by Thomas Schweikle.
*grub-0.97 (20 Aug 2005)
diff --git a/sys-boot/grub/Manifest b/sys-boot/grub/Manifest
index e1a0fadd578b..5b0bee9358b3 100644
--- a/sys-boot/grub/Manifest
+++ b/sys-boot/grub/Manifest
@@ -2,13 +2,13 @@
Hash: SHA1
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 70d277c51cf834fc480f28e631960cf6 grub-0.96-r2.ebuild 4588
-MD5 6a3fa6901a3a5d3e8a2435bc70b11051 grub-0.96-r1.ebuild 4733
-MD5 b47bf0819ddd6057262dbff2ee1a1d5a grub-0.96-r3.ebuild 4568
-MD5 1eef54e9c246858e8998857f8ca77e22 grub-0.94-r1.ebuild 3519
-MD5 f0a2b3429a6fe02a7ad675a392464a8a grub-0.97.ebuild 4484
+MD5 bb061c69fc3ad3e5484726111bacb933 grub-0.96-r2.ebuild 4597
+MD5 39a70f2e6c41b7e432c0f5603d01c1da grub-0.96-r1.ebuild 4742
+MD5 80623fad414fd78bb04b0479b94d76df grub-0.96-r3.ebuild 4577
+MD5 c634a95c2668abba2e886a917b363d5d grub-0.94-r1.ebuild 3528
+MD5 98aac6dc17a7d909ca1de859ef1394a2 grub-0.97.ebuild 4518
MD5 c8d30bf5c47b6d9cb935d2adb12a9ac9 grub-0.92-r1.ebuild 2629
-MD5 60953a0178bea28f654ff25560f17947 ChangeLog 15676
+MD5 ace1405356b6428d5d0b6c8251b32320 ChangeLog 15964
MD5 97d88870847fafcf5fe4162f6d273e74 files/digest-grub-0.96-r2 193
MD5 c5c746f1feb71d47fb2f5481590b83df files/digest-grub-0.94-r1 190
MD5 80b2642d044b2ad2983d3925c4531952 files/digest-grub-0.97 191
@@ -18,7 +18,7 @@ MD5 5695c7ea410b6913901208938e05b1ad files/digest-grub-0.92-r1 190
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDBnNrgIKl8Uu19MoRAkEIAJ9ABJt8otynVFOJH9OoiPeuOs0xAQCdE7F2
-txcgVBC0b4l2ufLM105PrDg=
-=ovDA
+iD8DBQFDB+XqgIKl8Uu19MoRAo9cAJ9/5TEAV5N4PkLr1q5xS6ZulmjaHwCdGwH+
+0Qe8shQm7vjzEVT8jc55pYg=
+=osBe
-----END PGP SIGNATURE-----
diff --git a/sys-boot/grub/grub-0.94-r1.ebuild b/sys-boot/grub/grub-0.94-r1.ebuild
index b1efaaaea99b..01e71b23bcad 100644
--- a/sys-boot/grub/grub-0.94-r1.ebuild
+++ b/sys-boot/grub/grub-0.94-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.23 2005/08/05 03:15:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.24 2005/08/21 02:24:04 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -92,7 +92,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- exeinto /usr/lib/grub
+ exeinto /usr/lib/grub/${CHOST}
doexe nbgrub pxegrub stage2/stage2 stage2/stage2.netboot
insinto /boot/grub
diff --git a/sys-boot/grub/grub-0.96-r1.ebuild b/sys-boot/grub/grub-0.96-r1.ebuild
index a4c853aabab6..2d483090d9e3 100644
--- a/sys-boot/grub/grub-0.96-r1.ebuild
+++ b/sys-boot/grub/grub-0.96-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.14 2005/08/20 00:03:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r1.ebuild,v 1.15 2005/08/21 02:24:04 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -113,7 +113,7 @@ src_test() {
src_install() {
make DESTDIR="${D}" install || die
- exeinto /usr/lib/grub
+ exeinto /usr/lib/grub/${CHOST}
use netboot && doexe nbgrub pxegrub stage2/stage2.netboot
insinto /boot/grub
diff --git a/sys-boot/grub/grub-0.96-r2.ebuild b/sys-boot/grub/grub-0.96-r2.ebuild
index 0b4de9c1c8fe..f9c1d4abc2c1 100644
--- a/sys-boot/grub/grub-0.96-r2.ebuild
+++ b/sys-boot/grub/grub-0.96-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.8 2005/08/20 00:03:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r2.ebuild,v 1.9 2005/08/21 02:24:04 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -113,7 +113,7 @@ src_test() {
src_install() {
make DESTDIR="${D}" install || die
- exeinto /usr/lib/grub
+ exeinto /usr/lib/grub/${CHOST}
use netboot && doexe nbgrub pxegrub stage2/stage2.netboot
insinto /boot/grub
diff --git a/sys-boot/grub/grub-0.96-r3.ebuild b/sys-boot/grub/grub-0.96-r3.ebuild
index cee42fba7382..28145f4d89da 100644
--- a/sys-boot/grub/grub-0.96-r3.ebuild
+++ b/sys-boot/grub/grub-0.96-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r3.ebuild,v 1.2 2005/08/20 00:03:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96-r3.ebuild,v 1.3 2005/08/21 02:24:04 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -112,7 +112,7 @@ src_test() {
src_install() {
make DESTDIR="${D}" install || die
- exeinto /usr/lib/grub
+ exeinto /usr/lib/grub/${CHOST}
use netboot && doexe nbgrub pxegrub stage2/stage2.netboot
insinto /boot/grub
diff --git a/sys-boot/grub/grub-0.97.ebuild b/sys-boot/grub/grub-0.97.ebuild
index 0a75510d9c61..2ca8af3edd43 100644
--- a/sys-boot/grub/grub-0.97.ebuild
+++ b/sys-boot/grub/grub-0.97.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97.ebuild,v 1.1 2005/08/20 00:03:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97.ebuild,v 1.2 2005/08/21 02:24:04 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -113,8 +113,8 @@ src_test() {
src_install() {
make DESTDIR="${D}" install || die
if use netboot ; then
- exeinto /usr/lib/grub
- doexe nbgrub pxegrub stage2/stage2.netboot
+ exeinto /usr/lib/grub/${CHOST}
+ doexe nbgrub pxegrub stage2/stage2.netboot || die "netboot install"
fi
insinto /boot/grub