summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-1.9.6-r3.ebuild')
-rw-r--r--sys-devel/automake/automake-1.9.6-r3.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/sys-devel/automake/automake-1.9.6-r3.ebuild b/sys-devel/automake/automake-1.9.6-r3.ebuild
index 19481dc10135..b555d73ceeff 100644
--- a/sys-devel/automake/automake-1.9.6-r3.ebuild
+++ b/sys-devel/automake/automake-1.9.6-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.6-r3.ebuild,v 1.12 2014/01/17 04:23:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.6-r3.ebuild,v 1.13 2014/11/15 06:07:49 vapier Exp $
+
+EAPI="4"
inherit eutils
@@ -9,21 +11,21 @@ HOMEPAGE="http://www.gnu.org/software/automake/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
+# Use Gentoo versioning for slotting.
SLOT="${PV:0:3}"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.59-r6
+ >=sys-devel/autoconf-2.69
>=sys-apps/texinfo-4.7
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
sys-apps/help2man"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ export WANT_AUTOCONF=2.5
epatch "${FILESDIR}"/${PN}-1.9.6-infopage-namechange.patch
epatch "${FILESDIR}"/${P}-include-dir-prefix.patch #107435
epatch "${FILESDIR}"/${P}-ignore-comments.patch #126388
@@ -31,7 +33,6 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.9.6-subst-test.patch #222225
epatch "${FILESDIR}"/${PN}-1.10-ccnoco-ldflags.patch #203914
epatch "${FILESDIR}"/${PN}-1.8.5-CVE-2009-4029.patch #295357
- export WANT_AUTOCONF=2.5
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -64,7 +65,7 @@ slot_info_pages() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
slot_info_pages
local x
@@ -74,8 +75,6 @@ src_install() {
rm -f "${D}"/usr/bin/${x}
done
- dodoc NEWS README THANKS TODO AUTHORS ChangeLog
-
# remove all config.guess and config.sub files replacing them
# w/a symlink to a specific gnuconfig version
for x in guess sub ; do