summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/apache/apache-2.4.7.ebuild')
-rw-r--r--www-servers/apache/apache-2.4.7.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/www-servers/apache/apache-2.4.7.ebuild b/www-servers/apache/apache-2.4.7.ebuild
index 8f4f09d33db6..4813c4c9fa4b 100644
--- a/www-servers/apache/apache-2.4.7.ebuild
+++ b/www-servers/apache/apache-2.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.4.7.ebuild,v 1.4 2014/01/24 03:39:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.4.7.ebuild,v 1.5 2014/01/31 08:30:59 vapier Exp $
EAPI=5
@@ -157,6 +157,20 @@ src_configure() {
apache-2_src_configure
}
+src_compile() {
+ if tc-is-cross-compiler; then
+ # This header is the same across targets, so use the build compiler.
+ pushd server >/dev/null
+ emake gen_test_char
+ tc-export_build_env BUILD_CC
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} \
+ gen_test_char.c -o gen_test_char $(apr-1-config --includes) || die
+ popd >/dev/null
+ fi
+
+ default
+}
+
src_install() {
apache-2_src_install
for i in /usr/bin/{htdigest,logresolve,htpasswd,htdbm,ab,httxt2dbm}; do