summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/evas/Manifest4
-rw-r--r--x11-libs/evas/evas-1.0.0.20030629_pre8.ebuild84
-rw-r--r--x11-libs/evas/files/digest-evas-1.0.0.20030629_pre81
3 files changed, 88 insertions, 1 deletions
diff --git a/x11-libs/evas/Manifest b/x11-libs/evas/Manifest
index 384fd940caef..5b656fbb6a87 100644
--- a/x11-libs/evas/Manifest
+++ b/x11-libs/evas/Manifest
@@ -1,3 +1,5 @@
+MD5 b945bcb8850cc9b903c699eb3e9e9387 files/digest-evas-1.0.0.20030629_pre8 78
+MD5 54e24b9aa8bdf855f806cd152a927464 files/digest-evas-1.0.0.20030220_pre5-r1 78
MD5 96df14a3e2da7bd0219341acd8ca79b5 ChangeLog 674
+MD5 2281b53488c6e6a7844b97e0a49a6ac9 evas-1.0.0.20030629_pre8.ebuild 2620
MD5 cd590a29748138019833d62d05fcedc8 evas-1.0.0.20030220_pre5-r1.ebuild 2623
-MD5 54e24b9aa8bdf855f806cd152a927464 files/digest-evas-1.0.0.20030220_pre5-r1 78
diff --git a/x11-libs/evas/evas-1.0.0.20030629_pre8.ebuild b/x11-libs/evas/evas-1.0.0.20030629_pre8.ebuild
new file mode 100644
index 000000000000..467cbc446f6d
--- /dev/null
+++ b/x11-libs/evas/evas-1.0.0.20030629_pre8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/evas-1.0.0.20030629_pre8.ebuild,v 1.1 2003/06/29 17:47:04 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="hardware-accelerated canvas API"
+HOMEPAGE="http://www.enlightenment.org/pages/evas.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wh0rd.tk/gentoo/distfiles/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha"
+IUSE="X mmx opengl jpeg png directfb fbcon"
+
+DEPEND="virtual/x11
+ >=media-libs/imlib2-1.0.6.2003*
+ >=dev-libs/eet-0.0.1.2003*
+ >=dev-db/edb-1.0.3.2003*
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ directfb? ( >=dev-libs/DirectFB-0.9.16 )
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ env NOCONFIGURE=yes ./autogen.sh || die "could not autogen"
+
+ # other *very* fun options:
+ # (just do `env EXTRA_CONF="--enable-cpu-sse" emerge evas`)
+ # --enable-cpu-p2-only enable assumption of pentium2/amd cpu
+ # --enable-cpu-p3-only enable assumption of pentium3 and up cpu
+ # --enable-cpu-sse enable sse code
+ # --enable-scale-sample enable sampling scaler code
+ # --enable-scale-smooth enable sampling scaler code
+ # --enable-scale-trilinear enable tri-linear scaler code
+
+ local myconf=""
+ # mmx causes segfaults atm :/
+# use mmx && myconf="${myconf} --enable-cpu-mmx"
+ use X && myconf="${myconf} --enable-software-x11"
+ use opengl && myconf="${myconf} --enable-gl-x11"
+ use directfb && myconf="${myconf} --enable-directfb"
+ use fbcon && myconf="${myconf} --enable-fb"
+
+ use alpha && append-flags -fPIC
+
+ econf \
+ --enable-image-loader-eet \
+ --enable-image-loader-edb \
+ --enable-fmemopen \
+ --enable-cpu-c \
+ --enable-scale-smooth \
+ --enable-scale-sample \
+ --enable-convert-8-rgb-332 \
+ --enable-convert-8-rgb-666 \
+ --enable-convert-8-rgb-232 \
+ --enable-convert-8-rgb-222 \
+ --enable-convert-8-rgb-221 \
+ --enable-convert-8-rgb-121 \
+ --enable-convert-8-rgb-111 \
+ --enable-convert-16-rgb-565 \
+ --enable-convert-16-rgb-555 \
+ --enable-convert-16-rgb-rot-0 \
+ --enable-convert-32-rgb-8888 \
+ --enable-convert-32-rgbx-8888 \
+ --enable-convert-32-bgr-8888 \
+ --enable-convert-32-bgrx-8888 \
+ --enable-convert-32-rgb-rot-0 \
+ `use_enable png image-loader-png` \
+ `use_enable jpeg image-loader-jpeg` \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ find ${D} -name CVS -type d -exec rm -rf '{}' \;
+ dodoc AUTHORS ChangeLog Doxyfile NEWS README TODO
+ dohtml -r doc
+}
diff --git a/x11-libs/evas/files/digest-evas-1.0.0.20030629_pre8 b/x11-libs/evas/files/digest-evas-1.0.0.20030629_pre8
new file mode 100644
index 000000000000..5c2b4b10e5d6
--- /dev/null
+++ b/x11-libs/evas/files/digest-evas-1.0.0.20030629_pre8
@@ -0,0 +1 @@
+MD5 7c8e44d6fbf950cd957b94a62c99b49c evas-1.0.0.20030629_pre8.tar.bz2 4194980