summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/tango-icon-theme/tango-icon-theme-0.6.4.ebuild')
-rw-r--r--x11-themes/tango-icon-theme/tango-icon-theme-0.6.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-themes/tango-icon-theme/tango-icon-theme-0.6.4.ebuild b/x11-themes/tango-icon-theme/tango-icon-theme-0.6.4.ebuild
new file mode 100644
index 000000000000..f3d0953f4c89
--- /dev/null
+++ b/x11-themes/tango-icon-theme/tango-icon-theme-0.6.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/tango-icon-theme/tango-icon-theme-0.6.4.ebuild,v 1.1 2006/01/11 00:32:45 metalgod Exp $
+
+DESCRIPTION="SVG icon theme from the Tango project"
+HOMEPAGE="http://tango-project.org/"
+SRC_URI="http://tango-project.org/releases/${P}.tar.gz"
+
+LICENSE="CCPL-Attribution-ShareAlike-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png"
+
+RDEPEND=">=x11-misc/icon-naming-utils-0.6
+ media-gfx/imagemagick
+ >=gnome-base/librsvg-2.12"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.20"
+
+src_compile() {
+ if use png; then
+ econf --enable-png-creation || die "configure failed"
+ else
+ econf || die "configure failed"
+ fi
+
+ emake || die "make failed"
+}
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS README
+}