aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-08-20 09:19:23 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-08-20 09:19:23 -0700
commit20ba2253158f1db8767fd3192961416a2c8cb709 (patch)
treeb8773fa1c3fc1a26f93f0428204c20c2ca8f3a95 /sys-apps
parenttesting wandboard audio config patch (diff)
downloadarm-20ba2253158f1db8767fd3192961416a2c8cb709.tar.gz
arm-20ba2253158f1db8767fd3192961416a2c8cb709.tar.bz2
arm-20ba2253158f1db8767fd3192961416a2c8cb709.zip
added arch-independent fstrim shell script daemon
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fstrimDaemon/fstrimDaemon-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/fstrimDaemon/fstrimDaemon-9999.ebuild b/sys-apps/fstrimDaemon/fstrimDaemon-9999.ebuild
new file mode 100644
index 0000000..e24f85d
--- /dev/null
+++ b/sys-apps/fstrimDaemon/fstrimDaemon-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+EGIT_REPO_URI="https://github.com/dobek/fstrimDaemon.git"
+
+inherit git-2
+
+DESCRIPTION="Shell script daemon for fstrim to maintain ssd drive performance"
+HOMEPAGE="https://github.com/dobek/fstrimDaemon"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="systemd"
+
+RDEPEND="sys-apps/util-linux"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dosbin usr/sbin/fstrimDaemon.sh
+ dodoc README.md
+ if ! use systemd ; then
+ doinitd etc/init.d/fstrimDaemon
+ doconfd etc/conf.d/fstrimDaemon
+ else
+ systemd_dounit usr/lib/systemd/system/fstrimDaemon.service
+ fi
+}
+