aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-05-01 14:31:49 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-05-01 14:31:49 -0700
commit582371e39a56926c9a5f4e70dbe755e0ee1aa8f9 (patch)
tree00991c62670ea75c229ab7a5a066af264b4c6274
parentInitial layout, repo_name and metadata.xml skeleton (diff)
downloadgen-b0rk-582371e39a56926c9a5f4e70dbe755e0ee1aa8f9.tar.gz
gen-b0rk-582371e39a56926c9a5f4e70dbe755e0ee1aa8f9.tar.bz2
gen-b0rk-582371e39a56926c9a5f4e70dbe755e0ee1aa8f9.zip
EAPI unsupported pkg test
-rw-r--r--eapi-test/unsupported/metadata.xml26
-rw-r--r--eapi-test/unsupported/unsupported-0.1.ebuild17
2 files changed, 43 insertions, 0 deletions
diff --git a/eapi-test/unsupported/metadata.xml b/eapi-test/unsupported/metadata.xml
new file mode 100644
index 0000000..d12805c
--- /dev/null
+++ b/eapi-test/unsupported/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+# $Id$
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed, the most common being maintainer.
+
+For a full description look at:
+https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<maintainer type="person">
+ <email>exampledev@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<maintainer type="project">
+ <email>exampleproject@gentoo.org</email>
+ <name>Gentoo Example Project</name>
+</maintainer>
+<longdescription>Test for an unsupported EAPI</longdescription>
+</pkgmetadata>
diff --git a/eapi-test/unsupported/unsupported-0.1.ebuild b/eapi-test/unsupported/unsupported-0.1.ebuild
new file mode 100644
index 0000000..203cf4d
--- /dev/null
+++ b/eapi-test/unsupported/unsupported-0.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=666
+
+DESCRIPTION="Unsupported EAPI"
+HOMEPAGE="http://example.com"
+SRC_URI="http://example.com"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"