summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2015-05-04 01:52:46 +0200
committerSebastian Pipping <sebastian@pipping.org>2015-05-04 01:52:46 +0200
commit30706bb642b762aae006c51d46b237cedf0d02dd (patch)
tree61a90f0480fe08b6963bc6d744da0033c000310f /grub2-themes/steam-big-picture/steam-big-picture-0_p20131110.ebuild
parentgrub2-themes/openSUSE: Slots 12.2, 12.3, 13.1, 13.2 (diff)
downloadgrub2-themes-30706bb642b762aae006c51d46b237cedf0d02dd.tar.gz
grub2-themes-30706bb642b762aae006c51d46b237cedf0d02dd.tar.bz2
grub2-themes-30706bb642b762aae006c51d46b237cedf0d02dd.zip
grub2-themes/steam-big-picture: 0_p20131110
Diffstat (limited to 'grub2-themes/steam-big-picture/steam-big-picture-0_p20131110.ebuild')
-rw-r--r--grub2-themes/steam-big-picture/steam-big-picture-0_p20131110.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/grub2-themes/steam-big-picture/steam-big-picture-0_p20131110.ebuild b/grub2-themes/steam-big-picture/steam-big-picture-0_p20131110.ebuild
new file mode 100644
index 0000000..13e508c
--- /dev/null
+++ b/grub2-themes/steam-big-picture/steam-big-picture-0_p20131110.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit grub2-theme
+
+MY_PN=Steam-Big-Picture-Grub-Theme
+MY_PV=d5d255c7ebb15cc918540dc74422bffcad8c13cc
+DESCRIPTION="Grub2 GFX theme Steam Big Picture"
+HOMEPAGE="https://github.com/LegendaryBibo/Steam-Big-Picture-Grub-Theme"
+SRC_URI="https://github.com/LegendaryBibo/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT BitstreamVera ArevFonts"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_PN}-${MY_PV}
+RESTRICT="bindist mirror"
+
+src_prepare() {
+ rm *.sh *.sh.x || die
+}
+
+src_install() {
+ insinto "${GRUB2_THEME_DIR}"/${PN}
+ doins -r .
+}