aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuincy Fleming <quincyf467@protonmail.com>2023-10-02 20:04:14 -0500
committerQuincy Fleming <quincyf467@protonmail.com>2023-10-02 20:04:14 -0500
commit3c61783003a71993daf9d907dbc9ca5b433ff0c0 (patch)
tree48ceddca8c4d7e15fad3f631a7c8b16e319cf878
parentdev-python/types-requests: add 2.31.0.7 (diff)
downloadguru-3c61783003a71993daf9d907dbc9ca5b433ff0c0.tar.gz
guru-3c61783003a71993daf9d907dbc9ca5b433ff0c0.tar.bz2
guru-3c61783003a71993daf9d907dbc9ca5b433ff0c0.zip
app-misc/clipboard: add 0.8.2 and modify ebuilds
Signed-off-by: Quincy Fleming <quincyf467@protonmail.com>
-rw-r--r--app-misc/clipboard/Manifest1
-rw-r--r--app-misc/clipboard/clipboard-0.8.0.ebuild26
-rw-r--r--app-misc/clipboard/clipboard-0.8.1.ebuild27
-rw-r--r--app-misc/clipboard/clipboard-0.8.2.ebuild40
-rw-r--r--app-misc/clipboard/files/disable-debug-info.patch19
-rw-r--r--app-misc/clipboard/files/disable-git-and-lto.patch79
-rw-r--r--app-misc/clipboard/metadata.xml3
7 files changed, 58 insertions, 137 deletions
diff --git a/app-misc/clipboard/Manifest b/app-misc/clipboard/Manifest
index e5bc79b7b..0d44b01e7 100644
--- a/app-misc/clipboard/Manifest
+++ b/app-misc/clipboard/Manifest
@@ -1,2 +1,3 @@
DIST clipboard-0.8.0.tar.gz 29340849 BLAKE2B 91635f16eee4c7fec588f3ceae34571e815680a34553ecf352f67b77c0749ad4c4ee848713d1b65d7e0a4dee0a2a597b29f59abab9082400dc02acba00ab7326 SHA512 b600e8425e48625ed2ad068500e381b1a0d40eacce92e05d45af21c1f5517dcac516287fbcdc1c03fe87cd5bdd5933258ffccf31460a03dfd7e306dc22442c63
DIST clipboard-0.8.1.tar.gz 31510477 BLAKE2B 25243b59af15ef692f466fcb2b6c35cdd05e2ebaee95ddf2b1c6a555c2225d2273c4d0cc7785fb2da8cfdf8a5afeac968a48cc191c45e1df6966a8dfcfccff0b SHA512 b4c2c857cc734c6470990348c67f31b706cb61b116794135d5e60073d8e5389d4c93ee410e47a9c07998bd3a6578013879ee5f997eda9613c864ea312b54da2e
+DIST clipboard-0.8.2.tar.gz 31616470 BLAKE2B 7b4a58836928d95f5d92a446651e0daa33eebc585cfcb7556bcb887eef413ecbc89e200902db1cee61cdb72e55f2b1cd3c7f35529d399c9094e67b186db42b2f SHA512 a83174ed66ba8fe06abf002136f64e39940e07883af6de2245a45915ee14840b95f1009efa549d87f8adb768535a77f19c859951a1868207689175a3761ed34b
diff --git a/app-misc/clipboard/clipboard-0.8.0.ebuild b/app-misc/clipboard/clipboard-0.8.0.ebuild
index 57d5d1c0a..f14f813c4 100644
--- a/app-misc/clipboard/clipboard-0.8.0.ebuild
+++ b/app-misc/clipboard/clipboard-0.8.0.ebuild
@@ -14,9 +14,12 @@ SRC_URI="https://github.com/Slackadays/${MY_PN}/archive/refs/tags/${PV}.tar.gz -
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="X wayland lto debug"
+IUSE="X wayland debug"
-RDEPEND="X? ( x11-libs/libX11 )
+RDEPEND="X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )
wayland? (
dev-libs/wayland-protocols
dev-libs/wayland
@@ -24,26 +27,13 @@ RDEPEND="X? ( x11-libs/libX11 )
"
S="${WORKDIR}/${MY_P}"
-PATCHES=(
- "${FILESDIR}/disable-git-and-lto.patch"
-)
-
-src_prepare() {
- if ! use wayland; then
- sed -i '/pkg_check_modules(WAYLAND_CLIENT wayland-client wayland-protocols)/d' CMakeLists.txt || die
- fi
-
- if ! use debug; then
- eapply "${FILESDIR}/disable-debug-info.patch"
- fi
- cmake_src_prepare
-}
-
src_configure() {
local mycmakeargs=(
"-DCMAKE_INSTALL_LIBDIR=$(get_libdir)"
- "-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=$(usex lto TRUE FALSE)"
+ "-DCMAKE_C_FLAGS=$(usex debug "${CFLAGS}" "${CFLAGS} -DNDEBUG")"
+ "-DCMAKE_CXX_FLAGS=$(usex debug "${CXXFLAGS}" "${CXXFLAGS} -DNDEBUG")"
"-DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex X OFF ON)"
+ "-DNO_WAYLAND=$(usex wayland FALSE TRUE)"
)
cmake_src_configure
}
diff --git a/app-misc/clipboard/clipboard-0.8.1.ebuild b/app-misc/clipboard/clipboard-0.8.1.ebuild
index 57d5d1c0a..a21cd5e9c 100644
--- a/app-misc/clipboard/clipboard-0.8.1.ebuild
+++ b/app-misc/clipboard/clipboard-0.8.1.ebuild
@@ -14,36 +14,27 @@ SRC_URI="https://github.com/Slackadays/${MY_PN}/archive/refs/tags/${PV}.tar.gz -
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="X wayland lto debug"
+IUSE="X wayland debug"
-RDEPEND="X? ( x11-libs/libX11 )
+RDEPEND="X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )
wayland? (
dev-libs/wayland-protocols
dev-libs/wayland
)
+ media-libs/alsa-lib
"
S="${WORKDIR}/${MY_P}"
-PATCHES=(
- "${FILESDIR}/disable-git-and-lto.patch"
-)
-
-src_prepare() {
- if ! use wayland; then
- sed -i '/pkg_check_modules(WAYLAND_CLIENT wayland-client wayland-protocols)/d' CMakeLists.txt || die
- fi
-
- if ! use debug; then
- eapply "${FILESDIR}/disable-debug-info.patch"
- fi
- cmake_src_prepare
-}
-
src_configure() {
local mycmakeargs=(
"-DCMAKE_INSTALL_LIBDIR=$(get_libdir)"
- "-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=$(usex lto TRUE FALSE)"
+ "-DCMAKE_C_FLAGS=$(usex debug "${CFLAGS}" "${CFLAGS} -DNDEBUG")"
+ "-DCMAKE_CXX_FLAGS=$(usex debug "${CXXFLAGS}" "${CXXFLAGS} -DNDEBUG")"
"-DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex X OFF ON)"
+ "-DNO_WAYLAND=$(usex wayland FALSE TRUE)"
)
cmake_src_configure
}
diff --git a/app-misc/clipboard/clipboard-0.8.2.ebuild b/app-misc/clipboard/clipboard-0.8.2.ebuild
new file mode 100644
index 000000000..312960b30
--- /dev/null
+++ b/app-misc/clipboard/clipboard-0.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="Clipboard"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Cut, copy, and paste anything in your terminal"
+HOMEPAGE="https://getclipboard.app/ https://github.com/Slackadays/Clipboard"
+SRC_URI="https://github.com/Slackadays/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X wayland debug"
+
+RDEPEND="X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )
+ wayland? (
+ dev-libs/wayland-protocols
+ dev-libs/wayland
+ )
+ media-libs/alsa-lib
+"
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DCMAKE_INSTALL_LIBDIR=$(get_libdir)"
+ "-DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex X OFF ON)"
+ "-DCMAKE_C_FLAGS=$(usex debug "${CFLAGS}" "${CFLAGS} -DNDEBUG")"
+ "-DCMAKE_CXX_FLAGS=$(usex debug "${CXXFLAGS}" "${CXXFLAGS} -DNDEBUG")"
+ "-DNO_WAYLAND=$(usex wayland FALSE TRUE)"
+ )
+ cmake_src_configure
+}
diff --git a/app-misc/clipboard/files/disable-debug-info.patch b/app-misc/clipboard/files/disable-debug-info.patch
deleted file mode 100644
index c69cfb30b..000000000
--- a/app-misc/clipboard/files/disable-debug-info.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-#Created by Quincy Fleming.
-#Disables debug info without using flag NDEBUG as unless forced it will be ignored in favor of the user's specified compiler flags
---- a/src/gui/include/all/clipboard/logging.hpp
-+++ b/src/gui/include/all/clipboard/logging.hpp
-@@ -17,7 +17,6 @@
- #include <iostream>
- #include <streambuf>
-
--#if defined(NDEBUG)
- class NullBuffer : public std::streambuf {
- public:
- int overflow(int c) override { return c; }
-@@ -26,6 +25,3 @@
- static NullBuffer nullBuffer;
- static std::ostream nullStream(&nullBuffer);
- static std::ostream& debugStream = nullStream;
--#else
--static std::ostream& debugStream = std::cerr;
--#endif
diff --git a/app-misc/clipboard/files/disable-git-and-lto.patch b/app-misc/clipboard/files/disable-git-and-lto.patch
deleted file mode 100644
index 42e5c81e1..000000000
--- a/app-misc/clipboard/files/disable-git-and-lto.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-#Created by Quincy Fleming
-#Disables git program as it will just result in fatal error during build (won't stop the build though. just annoying)
-#Also, this removes enabling of LTO by default and allows the user to choose wether or not they want LTO support via USE flag
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -11,22 +11,6 @@
- set(X11WL ON)
- endif()
-
--execute_process( # save the current branch to GIT_BRANCH
-- COMMAND git rev-parse --abbrev-ref HEAD
-- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
-- OUTPUT_VARIABLE GIT_BRANCH
-- OUTPUT_STRIP_TRAILING_WHITESPACE
--)
--
--execute_process( # save the current commit hash to GIT_COMMIT_HASH
-- COMMAND git log -1 --format=%h
-- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
-- OUTPUT_VARIABLE GIT_COMMIT_HASH
-- OUTPUT_STRIP_TRAILING_WHITESPACE
--)
--
--add_definitions(-DGIT_COMMIT_HASH="${GIT_COMMIT_HASH}")
--add_definitions(-DGIT_BRANCH="${GIT_BRANCH}")
- add_definitions(-DCLIPBOARD_VERSION="${PROJECT_VERSION}")
-
- if (MSVC)
-@@ -84,17 +68,6 @@
- set(CMAKE_LIBRARY_OUTPUT_DIRECTORY_MINSIZEREL ${LIB_LOCATION})
- set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_MINSIZEREL ${BIN_LOCATION})
-
--function(enable_lto this_target)
--include(CheckIPOSupported)
--check_ipo_supported(RESULT lto_supported)
--if(lto_supported AND NOT NO_LTO)
-- set_property(TARGET ${this_target} PROPERTY INTERPROCEDURAL_OPTIMIZATION TRUE)
-- if(CMAKE_COMPILER_IS_GNUCXX)
-- list(APPEND CMAKE_CXX_COMPILE_OPTIONS_IPO "-flto=auto") # set the thread amount to what is available on the CPU
-- endif()
--endif()
--endfunction()
--
- add_subdirectory(src/gui)
-
- find_package(X11)
---- a/src/cb/CMakeLists.txt
-+++ b/src/cb/CMakeLists.txt
-@@ -5,8 +5,6 @@
- src/themes.cpp
- )
-
--enable_lto(cb)
--
- target_link_libraries(cb gui)
-
- if(WIN32)
---- a/src/cbwayland/CMakeLists.txt
-+++ b/src/cbwayland/CMakeLists.txt
-@@ -60,8 +60,6 @@
- )
- add_dependencies(cbwayland cbwayland_generatedheaders)
-
--enable_lto(cbwayland)
--
- target_link_libraries(cbwayland
- ${WAYLAND_CLIENT_LIBRARIES}
- gui
---- a/src/cbx11/CMakeLists.txt
-+++ b/src/cbx11/CMakeLists.txt
-@@ -7,8 +7,6 @@
- gui
- )
-
--enable_lto(cbx11)
--
- target_include_directories(cbx11 PRIVATE ${X11_INCLUDE_DIR})
-
- install(TARGETS cbx11 LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
diff --git a/app-misc/clipboard/metadata.xml b/app-misc/clipboard/metadata.xml
index 8fd822047..f760dd38c 100644
--- a/app-misc/clipboard/metadata.xml
+++ b/app-misc/clipboard/metadata.xml
@@ -5,9 +5,6 @@
<email>quincyf467@protonmail.com</email>
<name>Quincy Fleming</name>
</maintainer>
- <use>
- <flag name="lto">Enable Link Time Optimization (LTO)</flag>
- </use>
<upstream>
<remote-id type="github">Slackadays/Clipboard</remote-id>
<doc lang="en">https://github.com/Slackadays/Clipboard/blob/main/README.md</doc>