aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2023-01-11 17:09:47 +0100
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2023-01-11 19:21:13 +0100
commit8023768b0c64d575dd87bf4c39b2827dcc9ed943 (patch)
tree500a963e0cff5df9b8488a44b3abac3baddd58f6 /app-vim
parentmpv-plugin/mpv_thumbnail_script: add multiple thumbnailer threads (diff)
downloadguru-8023768b0c64d575dd87bf4c39b2827dcc9ed943.tar.gz
guru-8023768b0c64d575dd87bf4c39b2827dcc9ed943.tar.bz2
guru-8023768b0c64d575dd87bf4c39b2827dcc9ed943.zip
app-vim/ale: new package, add 3.3.0
Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/ale/Manifest1
-rw-r--r--app-vim/ale/ale-3.3.0.ebuild17
-rw-r--r--app-vim/ale/metadata.xml8
3 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/ale/Manifest b/app-vim/ale/Manifest
new file mode 100644
index 000000000..784afac85
--- /dev/null
+++ b/app-vim/ale/Manifest
@@ -0,0 +1 @@
+DIST ale-3.3.0.tar.gz 401593 BLAKE2B 84a86e456e9c49b0bb409272f92a4ef7391b540bbd5da972b8d699570ef9709e4d64bec67b47b62d78e0ebd1be5b0f6bb84744fa8a34409ed8c7f7899784f885 SHA512 96cdeeac907871eaea698a57e391d25353c8509266253f2f89fff5f1eb0f52fe0f87099d6fd609480ed2c3adf61bb781a3e5f2858474cd8d20aba7074475aabc
diff --git a/app-vim/ale/ale-3.3.0.ebuild b/app-vim/ale/ale-3.3.0.ebuild
new file mode 100644
index 000000000..1a83959ec
--- /dev/null
+++ b/app-vim/ale/ale-3.3.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="Check syntax in Vim asynchronously and fix files, with LSP support"
+HOMEPAGE="https://github.com/dense-analysis/ale"
+SRC_URI="https://github.com/dense-analysis/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64"
+
+src_install(){
+ vim-plugin_src_install ale_linters rplugin
+}
diff --git a/app-vim/ale/metadata.xml b/app-vim/ale/metadata.xml
new file mode 100644
index 000000000..be3f1030e
--- /dev/null
+++ b/app-vim/ale/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>smaniotto.nicola@gmail.com</email>
+ <name>Nicola Smaniotto</name>
+ </maintainer>
+</pkgmetadata>