aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2023-10-16 17:06:10 +0200
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2023-10-16 17:06:10 +0200
commit9249b3ba6fec76cc2aa78258eac16da78e3b12d5 (patch)
treed3d35684dc87da880dc5ddc5d364fdbf110bc576 /games-arcade
parentgames-puzzle/aaaaxy: add 1.4.50, drop 1.4.18 (diff)
downloadguru-9249b3ba6fec76cc2aa78258eac16da78e3b12d5.tar.gz
guru-9249b3ba6fec76cc2aa78258eac16da78e3b12d5.tar.bz2
guru-9249b3ba6fec76cc2aa78258eac16da78e3b12d5.zip
games-arcade/SpaceCadetPinball: add 2.1.0
Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/SpaceCadetPinball/Manifest1
-rw-r--r--games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/games-arcade/SpaceCadetPinball/Manifest b/games-arcade/SpaceCadetPinball/Manifest
index 95cb3a26e3..da733fd063 100644
--- a/games-arcade/SpaceCadetPinball/Manifest
+++ b/games-arcade/SpaceCadetPinball/Manifest
@@ -1,2 +1,3 @@
DIST SpaceCadetPinball-2.0.1.tar.gz 1882629 BLAKE2B 55b2c4232880b065bad30371ad4c170ee2fbc485d2673d25d3afa82144d17bc6a74f70cee7dcc365992df61e95d65a97b57924e54a140b98790ee6e75b06cefd SHA512 b8a23c650a6251838c531a7f1427284199ba859fbdf8715a974404dbef3485503dffa723839f6b41d335e2afc73a85bd0fe0d670ebb7fc1462f089250f1f546f
DIST SpaceCadetPinball-2.0.tar.gz 933826 BLAKE2B b4a079ca856ebf315202eaae59a825d4c7022acfff7f38907ffd750f0e146da6d7c4f03286ef5c59ee5e3c725d938e30c2aad2f7269d9f18e8ae8f6807af80e1 SHA512 29b3f886d6ec6507c12a59b0c2877cbb51c54eee0163d0537588bb1e0fa0eb08b530d5684e8753598a823430559d5b3b9490be40ca9a3310043dac71912994c7
+DIST SpaceCadetPinball-2.1.0.tar.gz 3219590 BLAKE2B 93bbfb33cf4e4a05132764dab503a5e4f4db0295716279f9f0e077dcff145cd024fb626c6777dad888496590b81d9d999f928e5ea9a344effcf77484572a486e SHA512 0fff9049953af83b1a274fd5d845e2f19531cafae33b9fb337745169057f1a28b6eaaa1042a912fc5732eb10bb70e5ede174f2ca7873a267f368b8841bfa055d
diff --git a/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.1.0.ebuild b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.1.0.ebuild
new file mode 100644
index 0000000000..68d1514392
--- /dev/null
+++ b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Decompilation of 3D Pinball for Windows - Space Cadet"
+HOMEPAGE="https://github.com/k4zmu2a/SpaceCadetPinball"
+SRC_URI="https://github.com/k4zmu2a/${PN}/archive/refs/tags/Release_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/libsdl2
+ media-libs/sdl2-mixer[midi]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-Release_${PV}"
+
+pkg_postinst(){
+ ewarn "This game is distributed without the data files."
+ ewarn "To play, copy the original DAT and SOUND files from a Windows or"
+ ewarn 'Full Tilt! installation and place them in $XDG_DATA_HOME/'"${PN}/"
+ ewarn "(usually: ~/.local/share/${PN}/)"
+
+ xdg_pkg_postinst
+}