aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Levesque <wayne@ptaff.ca>2022-10-21 02:01:19 -0400
committerPatrice Levesque <wayne@ptaff.ca>2022-10-21 02:01:19 -0400
commitd694fd14999d5dc08804cd3d4ce27238fdb885e2 (patch)
tree4ee99fb19d9cbe10f692bab40f2cc3dc52cac142 /games-arcade
parentkde-misc/geminipart: add 20221020 (diff)
downloadguru-d694fd14999d5dc08804cd3d4ce27238fdb885e2.tar.gz
guru-d694fd14999d5dc08804cd3d4ce27238fdb885e2.tar.bz2
guru-d694fd14999d5dc08804cd3d4ce27238fdb885e2.zip
games-arcade/SpaceCadetPinball: add git head as 9999.
Upstream has not created a release for 10 months. Signed-off-by: Patrice Levesque <wayne@ptaff.ca>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/SpaceCadetPinball/SpaceCadetPinball-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-arcade/SpaceCadetPinball/SpaceCadetPinball-9999.ebuild b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-9999.ebuild
new file mode 100644
index 000000000..6133ee28a
--- /dev/null
+++ b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_REPO_URI="https://github.com/k4zmu2a/SpaceCadetPinball.git"
+
+inherit cmake git-r3 xdg
+
+DESCRIPTION="Decompilation of 3D Pinball for Windows - Space Cadet"
+HOMEPAGE="https://github.com/k4zmu2a/SpaceCadetPinball"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ media-libs/libsdl2
+ media-libs/sdl2-mixer[midi]
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst(){
+ ewarn "This game is distributed without the data files."
+ ewarn "To play, copy the original DAT and SOUND files from a Windows or"
+ ewarn 'Full Tilt! installation and place them in $XDG_DATA_HOME/'"${PN}/"
+ ewarn "(usually: ~/.local/share/${PN}/)"
+
+ xdg_pkg_postinst
+}