aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2024-05-20 11:22:25 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2024-05-20 11:28:05 +0200
commitb887f009c53d67fa949c57c6c2598a2c0df44843 (patch)
treea076c8dc6191fbc02b4d87894c276da77f4e6374 /net-dialup
parentapp-misc/dbf: fix RDEPEND (diff)
downloadguru-b887f009c53d67fa949c57c6c2598a2c0df44843.tar.gz
guru-b887f009c53d67fa949c57c6c2598a2c0df44843.tar.bz2
guru-b887f009c53d67fa949c57c6c2598a2c0df44843.zip
net-dialup/tio: add 3.3
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/tio/Manifest1
-rw-r--r--net-dialup/tio/tio-3.3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-dialup/tio/Manifest b/net-dialup/tio/Manifest
index 5a6213db9..8e32e6a0c 100644
--- a/net-dialup/tio/Manifest
+++ b/net-dialup/tio/Manifest
@@ -1 +1,2 @@
DIST tio-3.2.tar.xz 3452984 BLAKE2B 32abe46a8d010ed18b3eec7426788d07c73e7d87d1d3d6fb5bfc08b15cbdc4acaf5e49123d7b9fc1e6559bdae0e21fb20ceb945b97046508349d63423b02b9ba SHA512 37ee36a52b0a41bd8e8fdc0329036fdaedd3130d2e19a92c8f14d86fd2193a5ed1354893c3a8f05e102db5fcb496993fb1700303fd0d2820b9e519abb33976cf
+DIST tio-3.3.tar.xz 3453004 BLAKE2B 3cd9da5f69b8e9b0028846cc5b9ea8110df6a592c53f13aa64bd144aec9fb20ace56d5ee750a0b4ee589e389feb4bcb0cba7a11fe7193f4ced40d3251b47b2d7 SHA512 f4eeb274cd74fdd22f22cf5024966268f656fd7bb9a413eb26fdb886f0b783540ffc1e5ddd740952e09c0a630d3cae2f72054c5edd705a6e272a2634b4a42498
diff --git a/net-dialup/tio/tio-3.3.ebuild b/net-dialup/tio/tio-3.3.ebuild
new file mode 100644
index 000000000..dead597a8
--- /dev/null
+++ b/net-dialup/tio/tio-3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+
+inherit lua-single meson bash-completion-r1
+
+DESCRIPTION="Simple TTY terminal application"
+HOMEPAGE="https://tio.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RDEPEND="
+ ${LUA_DEPS}
+ dev-libs/glib
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dbashcompletiondir="$(get_bashcompdir)"
+ )
+
+ meson_src_configure
+}