aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authortea <gentoo@tastytea.de>2024-06-13 15:25:07 +0200
committertea <gentoo@tastytea.de>2024-06-13 15:25:07 +0200
commiteff43b54fa21da39ca71c894f416a27043484e43 (patch)
tree0b8e86fc062a94a858ccfc04ccf2cc21cda05def /net-im
parentdev-cpp/qt-jdenticon: add 0.3.1 (diff)
downloadguru-eff43b54fa21da39ca71c894f416a27043484e43.tar.gz
guru-eff43b54fa21da39ca71c894f416a27043484e43.tar.bz2
guru-eff43b54fa21da39ca71c894f416a27043484e43.zip
net-im/nheko: add 0.12.0
Signed-off-by: tea <gentoo@tastytea.de>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/nheko/Manifest1
-rw-r--r--net-im/nheko/nheko-0.12.0.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/net-im/nheko/Manifest b/net-im/nheko/Manifest
index 17bbfb1b5..c923ee692 100644
--- a/net-im/nheko/Manifest
+++ b/net-im/nheko/Manifest
@@ -1 +1,2 @@
DIST nheko-v0.11.3.tar.bz2 1222761 BLAKE2B 218246824512b13fc3448142e5e127b207952e3f66c2b308ca281d7f9e6b0198760d9408b467bf9442a0df306d2b23ffc5034cba5c675299aac85ac4ebe23280 SHA512 bd051144a16cd628d6259a7ce4acf10fd7b7ef3d8b0036cbf1f2a80c550062a04062a61c66e7a060f853d53c1eaa50fadb0223641e98283001aabf037c0e4de1
+DIST nheko-v0.12.0.tar.bz2 1438636 BLAKE2B 6586b913f5221d2d8da5e56eb23fd0ef4ad79f4d4649244308787fd2e6c54d3ddfea32e4723676386a1681370e51c8af73c3a58fc77b536e6fa44ad0bdac2e7a SHA512 8fd96c3d40c75250b9c66eef673d709392d6afe1e9c7a8ad8cb3015633583fb2358c9e714da19c5616640c6c2ff8027871293718b0fcdb0f5d6a5ea0f27e7a3f
diff --git a/net-im/nheko/nheko-0.12.0.ebuild b/net-im/nheko/nheko-0.12.0.ebuild
new file mode 100644
index 000000000..d51334d1e
--- /dev/null
+++ b/net-im/nheko/nheko-0.12.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature xdg
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="Native desktop client for Matrix using Qt"
+HOMEPAGE="https://github.com/Nheko-Reborn/nheko"
+SRC_URI="https://nheko.im/nheko-reborn/${PN}/-/archive/v${PV}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X doc +pie +man video voip"
+REQUIRED_USE="video? ( voip )"
+
+MY_GST_V="1.18"
+RDEPEND="
+ app-text/cmark:=
+ >=dev-cpp/blurhash-0.2.0:=
+ >=dev-cpp/coeurl-0.3.1:=[ssl]
+ dev-cpp/cpp-httplib:=
+ dev-db/lmdb:=
+ >=dev-db/lmdb++-1.0.0
+ dev-libs/libevent:=
+ dev-libs/libfmt:=
+ >=dev-libs/mtxclient-0.10.0:=
+ dev-libs/olm
+ >=dev-libs/openssl-1.1.0:=
+ >=dev-libs/qtkeychain-0.14.1-r1:=[qt6]
+ >=dev-libs/re2-0.2022.04.01:=
+ dev-libs/spdlog:=
+ >=dev-qt/kdsingleapplication-1.1.0:=[qt6]
+ dev-qt/qtbase:6[concurrent,dbus,gui,widgets]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtimageformats:6
+ dev-qt/qtmultimedia:6[gstreamer]
+ dev-qt/qtsvg:6
+ net-misc/curl[ssl]
+ virtual/notification-daemon
+ voip? (
+ >=media-plugins/gst-plugins-dtls-${MY_GST_V}
+ media-plugins/gst-plugins-libnice
+ >=media-plugins/gst-plugins-meta-${MY_GST_V}[opus]
+ >=media-plugins/gst-plugins-srtp-${MY_GST_V}
+ >=media-plugins/gst-plugins-webrtc-${MY_GST_V}
+ video? (
+ >=media-libs/gst-plugins-base-${MY_GST_V}[opengl]
+ >=media-plugins/gst-plugins-meta-${MY_GST_V}[v4l,vpx]
+ X? (
+ >=media-plugins/gst-plugins-ximagesrc-${MY_GST_V}
+ )
+ )
+ )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm
+ )
+"
+# TODO: gst-plugins-qt6 for video calls
+DEPEND="
+ dev-cpp/nlohmann_json
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-qt/qttools:6[linguist]
+ doc? ( app-text/doxygen[dot] )
+ man? (
+ || (
+ app-text/asciidoc
+ dev-ruby/asciidoctor
+ )
+ )
+"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DUSE_BUNDLED_CPPHTTPLIB=no
+ -DUSE_BUNDLED_BLURHASH=no
+
+ -DVOIP=$(usex voip)
+ -DX11=$(usex X)
+ -DBUILD_DOCS=$(usex doc)
+ -DMAN=$(usex man)
+
+ # See #890903 and #911111
+ -DCMAKE_POSITION_INDEPENDENT_CODE=$(usex pie)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ optfeature "audio & video file playback support" \
+ "media-plugins/gst-plugins-meta[ffmpeg]"
+ optfeature "secrets storage support other than kwallet (for example gnome-keyring or keepassxc)" \
+ "dev-libs/qtkeychain[keyring]"
+ optfeature "additional, less common, image format support" \
+ "kde-frameworks/kimageformats:6"
+ optfeature "identicons support" dev-cpp/qt-jdenticon:6
+
+ xdg_pkg_postinst
+
+ ewarn "since Nheko migrated to Qt 6 video streams will not work for now because"
+ ewarn "we are missing a dependency. see <https://bugs.gentoo.org/810814> for details"
+}