aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-06-03 02:31:46 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-06-03 03:18:01 +0200
commit5d0270aaf228fe067d2226de9888908bb23e6a09 (patch)
tree0e8f9fdc62435f96fa101a497c31c9441d528382 /net-misc
parentgames-util/mangohud: add 0.7.1-r6, drop 0.7.1-r5 (diff)
downloadguru-5d0270aaf228fe067d2226de9888908bb23e6a09.tar.gz
guru-5d0270aaf228fe067d2226de9888908bb23e6a09.tar.bz2
guru-5d0270aaf228fe067d2226de9888908bb23e6a09.zip
net-misc/FORT-validator: declare read-only parameter's type as const
Fixes build failure due to -Wincompatible-pointer-types Closes: https://bugs.gentoo.org/928331 Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/FORT-validator/FORT-validator-1.5.4-r1.ebuild (renamed from net-misc/FORT-validator/FORT-validator-1.5.4.ebuild)4
-rw-r--r--net-misc/FORT-validator/FORT-validator-1.6.1-r1.ebuild (renamed from net-misc/FORT-validator/FORT-validator-1.6.1.ebuild)4
-rw-r--r--net-misc/FORT-validator/FORT-validator-1.6.2-r1.ebuild (renamed from net-misc/FORT-validator/FORT-validator-1.6.2.ebuild)4
-rw-r--r--net-misc/FORT-validator/files/FORT-validator-1.5.4-GCC14.patch28
4 files changed, 37 insertions, 3 deletions
diff --git a/net-misc/FORT-validator/FORT-validator-1.5.4.ebuild b/net-misc/FORT-validator/FORT-validator-1.5.4-r1.ebuild
index 3d59fe305..b6df06436 100644
--- a/net-misc/FORT-validator/FORT-validator-1.5.4.ebuild
+++ b/net-misc/FORT-validator/FORT-validator-1.5.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,6 +18,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="caps"
+PATCHES="${FILESDIR}"/${PN}-1.5.4-GCC14.patch
+
DEPEND="
acct-group/fort
acct-user/fort
diff --git a/net-misc/FORT-validator/FORT-validator-1.6.1.ebuild b/net-misc/FORT-validator/FORT-validator-1.6.1-r1.ebuild
index c4ee310ed..1eb18db5b 100644
--- a/net-misc/FORT-validator/FORT-validator-1.6.1.ebuild
+++ b/net-misc/FORT-validator/FORT-validator-1.6.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,6 +18,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="caps"
+PATCHES="${FILESDIR}"/${PN}-1.5.4-GCC14.patch
+
DEPEND="
acct-group/fort
acct-user/fort
diff --git a/net-misc/FORT-validator/FORT-validator-1.6.2.ebuild b/net-misc/FORT-validator/FORT-validator-1.6.2-r1.ebuild
index 89351a5ad..7e33ba238 100644
--- a/net-misc/FORT-validator/FORT-validator-1.6.2.ebuild
+++ b/net-misc/FORT-validator/FORT-validator-1.6.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,6 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="caps"
+PATCHES="${FILESDIR}"/${PN}-1.5.4-GCC14.patch
+
DEPEND="
acct-group/fort
acct-user/fort
diff --git a/net-misc/FORT-validator/files/FORT-validator-1.5.4-GCC14.patch b/net-misc/FORT-validator/files/FORT-validator-1.5.4-GCC14.patch
new file mode 100644
index 000000000..7a417fd24
--- /dev/null
+++ b/net-misc/FORT-validator/files/FORT-validator-1.5.4-GCC14.patch
@@ -0,0 +1,28 @@
+https://github.com/NICMx/FORT-validator/pull/137
+
+Since we don't manipulate any struct members, I believe we can safely take a
+const xmlError * argument instead, as per libxml2's documentation .
+
+I also believe we can drop the string-termination handling, because C strings
+end with \0 and therefore ptr[strlen(ptr)-1] is always \0.
+
+Author: Lucio Sauer <watermanpaint@posteo.net>
+--- a/src/xml/relax_ng.c
++++ b/src/xml/relax_ng.c
+@@ -36,14 +36,9 @@ relax_ng_log_warn(void *ctx, const char *msg, ...)
+ }
+
+ static void
+-relax_ng_log_str_err(void *userData, xmlErrorPtr error)
++relax_ng_log_str_err(void *userData, const xmlError *error)
+ {
+- char *ptr;
+-
+- ptr = error->message;
+- if (ptr[strlen(ptr) - 1] == '\n')
+- ptr[strlen(ptr) - 1] = '\0';
+- pr_val_err("%s (at line %d)", ptr, error->line);
++ pr_val_err("%s (at line %d)", error->message, error->line);
+ }
+
+ /* Initialize global schema to parse RRDP files */