aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-02-04 12:23:48 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-02-05 00:11:01 +0500
commit6f44d5a41b3e7f12000141bd5af035604b3f2f4e (patch)
treeb496e74d08836c1c4e53f90380f46e0cff3e7ddf /phosh-base
parentphosh-base/phosh-shell: rename gui-wm/phosh (diff)
downloadguru-6f44d5a41b3e7f12000141bd5af035604b3f2f4e.tar.gz
guru-6f44d5a41b3e7f12000141bd5af035604b3f2f4e.tar.bz2
guru-6f44d5a41b3e7f12000141bd5af035604b3f2f4e.zip
phosh-base/phosh-tour: rename gui-apps/phosh-tour
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'phosh-base')
-rw-r--r--phosh-base/phosh-tour/Manifest2
-rw-r--r--phosh-base/phosh-tour/metadata.xml11
-rw-r--r--phosh-base/phosh-tour/phosh-tour-0.35.0.ebuild49
-rw-r--r--phosh-base/phosh-tour/phosh-tour-0.36.0.ebuild47
4 files changed, 109 insertions, 0 deletions
diff --git a/phosh-base/phosh-tour/Manifest b/phosh-base/phosh-tour/Manifest
new file mode 100644
index 0000000000..4ceb65f155
--- /dev/null
+++ b/phosh-base/phosh-tour/Manifest
@@ -0,0 +1,2 @@
+DIST phosh-tour-0.36.0.tar.xz 113636 BLAKE2B 21803419b5e70d7fbb38da23d266905eb254b7f38653d222b7da062c603071ff682a4c92ec673e50850d4cdadc5fc82c2b59fa7d1c87d9a5827bc12ab4f0a35b SHA512 c0d493be60462fe801a72d957ab2f36aafd7fcb5a515f087094ca9723889b8725c241d251cf5e6a0fe2b895417b8779b3c4efe19eb8372e4da9ec812b849dc15
+DIST phosh-tour-v0.35.0.tar.bz2 121098 BLAKE2B cd229c7d7a406dd4cea1a4e5bdf6c271f93025c2337d974873995c7b000316d7d210dcf729955d3c49dbb6360f79d1d28d6198c257142dd252cf263ab1089693 SHA512 af435e228f4a3151accf122faf7eb33d1198ccc890fee8d45e9005dfa3887a5fd0ae7a931756a707bcbe0511c20a54e1adf967873dca126f9904bf43174769c3
diff --git a/phosh-base/phosh-tour/metadata.xml b/phosh-base/phosh-tour/metadata.xml
new file mode 100644
index 0000000000..ceaeeda064
--- /dev/null
+++ b/phosh-base/phosh-tour/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gnome-gitlab">guidog/phosh-tour</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/phosh-base/phosh-tour/phosh-tour-0.35.0.ebuild b/phosh-base/phosh-tour/phosh-tour-0.35.0.ebuild
new file mode 100644
index 0000000000..b664e5288e
--- /dev/null
+++ b/phosh-base/phosh-tour/phosh-tour-0.35.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson xdg
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="Introduction to phosh on smartphones"
+HOMEPAGE="https://gitlab.gnome.org/guidog/phosh-tour"
+SRC_URI="https://gitlab.gnome.org/guidog/${PN}/-/archive/v${PV}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/glib:2
+ >=gui-libs/gtk-4.4:4
+ >=gui-libs/libadwaita-1.1:1
+"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-devel/gettext"
+
+QA_DESKTOP_FILE="usr/share/applications/mobi.phosh.PhoshTour.desktop"
+
+src_configure() {
+ local emesonargs=(
+ -Dbrand="smartphone"
+ -Dvendor="Gentoo"
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # No useful tests
+ :
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/phosh-base/phosh-tour/phosh-tour-0.36.0.ebuild b/phosh-base/phosh-tour/phosh-tour-0.36.0.ebuild
new file mode 100644
index 0000000000..383044b173
--- /dev/null
+++ b/phosh-base/phosh-tour/phosh-tour-0.36.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson xdg
+
+DESCRIPTION="Introduction to phosh on smartphones"
+HOMEPAGE="https://gitlab.gnome.org/guidog/phosh-tour"
+SRC_URI="https://sources.phosh.mobi/releases/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/glib:2
+ >=gui-libs/gtk-4.4:4
+ >=gui-libs/libadwaita-1.1:1
+"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-devel/gettext"
+
+QA_DESKTOP_FILE="usr/share/applications/mobi.phosh.PhoshTour.desktop"
+
+src_configure() {
+ local emesonargs=(
+ -Dbrand="smartphone"
+ -Dvendor="Gentoo"
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # No useful tests
+ :
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}