aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Lloro <ivan.lloro.boada@gmail.com>2024-08-05 19:20:41 +0200
committerIvan Lloro <ivan.lloro.boada@gmail.com>2024-08-05 19:21:12 +0200
commit3c6b3b7b9215e0003bc6abbdeee49a080dadef4c (patch)
treeea982a65b1b55ca4ed05f6e1ef5b20831fc0453e /sci-physics
parentx11-misc/betterlockscreen: drop 4.2.0 (diff)
downloadguru-3c6b3b7b9215e0003bc6abbdeee49a080dadef4c.tar.gz
guru-3c6b3b7b9215e0003bc6abbdeee49a080dadef4c.tar.bz2
guru-3c6b3b7b9215e0003bc6abbdeee49a080dadef4c.zip
sci-physics/openmodelica: Refactor direct fortran compilation approach
Signed-off-by: Ivan Lloro <ivan.lloro.boada@gmail.com>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/openmodelica/openmodelica-1.23.1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-physics/openmodelica/openmodelica-1.23.1.ebuild b/sci-physics/openmodelica/openmodelica-1.23.1.ebuild
index b14cc60dd..20d67e22b 100644
--- a/sci-physics/openmodelica/openmodelica-1.23.1.ebuild
+++ b/sci-physics/openmodelica/openmodelica-1.23.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake desktop xdg toolchain-funcs fortran-2
+inherit cmake desktop xdg fortran-2
DESCRIPTION="Open-source Modelica-based modeling and simulation environment"
HOMEPAGE="https://openmodelica.org/"
@@ -128,7 +128,7 @@ src_compile() {
# OMSens is disabled in "${WORKDIR}/${P}/CMakeLists.txt" (## omc_add_subdirectory(OMSens)) due to lack of a
# working "${WORKDIR}/${P}/OMSens/CMakeLists.txt". So, we compile it manually.
pushd OMSens/fortran_interface > /dev/null || die
- $(tc-getFC) -fPIC -c Rutf.for Rut.for Curvif.for || die
+ ${FC} -fPIC -c Rutf.for Rut.for Curvif.for || die
# BUG: Undefined symbol curvif_ in
# ${WORKDIR}/${P}/OMSens/fortran_interface/curvif_simplified.cpython-312-x86_64-linux-gnu.so
# See with nm or objdump -tT