aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-04 21:05:16 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-04 21:32:03 +0200
commit85ef5e1f3a6567e0bce34a14c0a6472397ce1cfe (patch)
tree67d0bf93b203ca33657fb8aba597504219b4b5a5 /sys-auth
parentsys-cluster/neutron: add 20.0.0, drop 20.0.0.0_rc1 (diff)
downloadguru-85ef5e1f3a6567e0bce34a14c0a6472397ce1cfe.tar.gz
guru-85ef5e1f3a6567e0bce34a14c0a6472397ce1cfe.tar.bz2
guru-85ef5e1f3a6567e0bce34a14c0a6472397ce1cfe.zip
sys-auth/keystone: add 21.0.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/Manifest1
-rw-r--r--sys-auth/keystone/keystone-21.0.0.ebuild169
2 files changed, 170 insertions, 0 deletions
diff --git a/sys-auth/keystone/Manifest b/sys-auth/keystone/Manifest
index aed973eb6..03002791a 100644
--- a/sys-auth/keystone/Manifest
+++ b/sys-auth/keystone/Manifest
@@ -1 +1,2 @@
DIST keystone-21.0.0.0rc1.tar.gz 1698152 BLAKE2B 703fb7b56a12cc3909a8990a2c21df2fca056f5eda43bd562ff8dcaeb06aa61db60b6d2ba6010d5c987f74f8d529eb66f086e648cbef25f96867e6c6b2644b29 SHA512 290e7ce13de1d7a232ef41166d51585460f6be745daf5477b8d83a8537f09eaecb82d6fabf554be777108b4a281ffb2e65457fe815a0405355a9e19c6f31f442
+DIST keystone-21.0.0.tar.gz 1697791 BLAKE2B e7c81ffa3d94ff12bd3aaeeaf4d8d7238b6d62c124419af9c8572ac47ace6eaa290bf922642d3c517dbd7ffab8b4a65705868ccea2c3715d85373bd830894961 SHA512 2214a96e058e553da5ab61423f3ebe3ba0e56a4a431d8109f845c2b967c4f2b98f5f1a15102b3b0c68ec48ebb1a3397b96576be98e991db601e916ff4e947043
diff --git a/sys-auth/keystone/keystone-21.0.0.ebuild b/sys-auth/keystone/keystone-21.0.0.ebuild
new file mode 100644
index 000000000..662dd4ae7
--- /dev/null
+++ b/sys-auth/keystone/keystone-21.0.0.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MYP="${P/_/}"
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1 tmpfiles
+
+DESCRIPTION="The Openstack authentication, authorization, and service catalog"
+HOMEPAGE="
+ https://opendev.org/openstack/keystone
+ https://launchpad.net/keystone
+ https://pypi.org/project/keystone/
+"
+SRC_URI="https://tarballs.openstack.org/${PN}/${MYP}.tar.gz"
+S="${WORKDIR}/${MYP}"
+
+KEYWORDS="~amd64"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+sqlite ldap memcached mongo mysql postgres"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/flask-restful-0.3.5[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.7[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-migrate-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/keystonemiddleware-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
+ >=dev-python/scrypt-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-cache-1.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-6.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-messaging-5.29.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-db-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.44.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-middleware-3.31.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-policy-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-upgradecheck-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/pysaml2-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pycadf-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+
+ ldap? (
+ >=dev-python/python-ldap-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/ldappool-2.3.1[${PYTHON_USEDEP}]
+ )
+ mysql? (
+ >=dev-python/pymysql-0.7.6[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.3.0[${PYTHON_USEDEP}]
+ )
+ memcached? (
+ >=dev-python/python-memcached-1.56[${PYTHON_USEDEP}]
+ )
+ mongo? (
+ >=dev-python/pymongo-3.0.2[${PYTHON_USEDEP}]
+ )
+ postgres? (
+ >=dev-python/psycopg-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.3.0[${PYTHON_USEDEP}]
+ )
+ sqlite? (
+ >=dev-python/sqlalchemy-1.3.0[sqlite,${PYTHON_USEDEP}]
+ )
+
+ || (
+ www-servers/uwsgi[python,${PYTHON_USEDEP}]
+ www-apache/mod_wsgi[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+ acct-user/keystone
+ acct-group/keystone
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ >=dev-python/bashate-0.5.1[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-0.3.6[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-db-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-2.0.27[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tempest-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-no-usr-local-bin.patch" )
+REQUIRED_USE="
+ || ( mysql postgres sqlite )
+ test? ( ldap )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ # allow usage of renamed msgpack
+ sed -i '/^msgpack/d' requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ oslo-config-generator --config-file=config-generator/keystone.conf || die
+ oslopolicy-sample-generator --config-file config-generator/keystone-policy-generator.conf || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ diropts -m 0750
+ keepdir /etc/keystone /var/log/keystone
+ insinto /etc/keystone
+ insopts -m 0640 -o keystone -g keystone
+ doins etc/keystone.conf.sample
+ doins etc/keystone.policy.yaml.sample
+ doins etc/logging.conf.sample
+ doins etc/default_catalog.templates
+ insinto /etc/keystone/httpd
+ doins httpd/*
+
+ fowners keystone:keystone /etc/keystone /etc/keystone/httpd /var/log/keystone
+
+ newtmpfiles "${FILESDIR}/keystone.tmpfile" keystone.conf
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/keystone.logrotate" keystone.conf
+
+ rm -r "${ED}/usr/etc" || die
+}
+
+pkg_postinst() {
+ elog "You might want to run:"
+ elog "emerge --config =${CATEGORY}/${PF}"
+ elog "if this is a new install."
+ elog "If you have not already configured your openssl installation"
+ elog "please do it by modifying /etc/ssl/openssl.cnf"
+ elog "BEFORE issuing the configuration command."
+ elog "Otherwise default values will be used."
+}
+
+pkg_config() {
+ if [ ! -d "${ROOT}/etc/keystone/ssl" ] ; then
+ einfo "Press ENTER to configure the keystone PKI, or Control-C to abort now..."
+ read
+ "${ROOT}/usr/bin/keystone-manage" pki_setup --keystone-user keystone --keystone-group keystone
+ else
+ einfo "keystone PKI certificates directory already present, skipping configuration"
+ fi
+}