aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiFei Zhu <zhuyifei1999@gmail.com>2024-01-11 21:44:01 -0800
committerYiFei Zhu <zhuyifei1999@gmail.com>2024-01-11 21:47:16 -0800
commitf993cd4056a31c9c10dc78bf68e4d5bbee657e5a (patch)
treec9a5c2332523c798fce517a6639c1e9e9c809c0c /sys-process
parentsys-kernel/ugrd: Add 0.20.0, bump dependecny versions (diff)
downloadguru-f993cd4056a31c9c10dc78bf68e4d5bbee657e5a.tar.gz
guru-f993cd4056a31c9c10dc78bf68e4d5bbee657e5a.tar.bz2
guru-f993cd4056a31c9c10dc78bf68e4d5bbee657e5a.zip
sys-process/nvtop: add 3.0.2, fix 9999
Signed-off-by: YiFei Zhu <zhuyifei1999@gmail.com>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/nvtop/Manifest1
-rw-r--r--sys-process/nvtop/nvtop-3.0.2.ebuild49
-rw-r--r--sys-process/nvtop/nvtop-9999.ebuild6
3 files changed, 54 insertions, 2 deletions
diff --git a/sys-process/nvtop/Manifest b/sys-process/nvtop/Manifest
index 4a2376560..daa7d50d5 100644
--- a/sys-process/nvtop/Manifest
+++ b/sys-process/nvtop/Manifest
@@ -1,3 +1,4 @@
DIST nvidia-settings-455.38.tar.bz2 1057087 BLAKE2B 81a287aecd2d0e788b0fe581c3dd10aa0f1fff19746b04a426a2ce9c7fa9dd9492cc5162c6bcd42496735c1b11482c3d9409aba5ec297e69afc19ddf11b1907c SHA512 56f5684ad3258c5449d747894a441aaef17403fc5406a3d61e0d7ffd983e908e3f909dc933b57dd9c98a47c4be7205c62157ce7097bf3937b3a8145e77fb354d
DIST nvtop-2.0.3.tar.gz 221071 BLAKE2B a1bd8d3e58aac36e1d21b79d8310e41efe3237a3df603d60115230eee76b1f106bd48dd48ab8ad99e3f1c42ebc895fb45efc46ada9169cbcdb5df93326f9e680 SHA512 ffd9d88898b7c6365d8bcff3c7b187760bc0036fba80ab6a0e3a586217ebf48b3377cdbe84f2fbbe10fb650f96de108973f95ccd29766e45da3901ee5d45f63c
DIST nvtop-3.0.1.tar.gz 234246 BLAKE2B bc93ee28e81490a43fabfcbad441bf76b49890699afcabf19146aba9b87734cd6d0ff292f05ec05aab4642b0828fc1fe6de2dd2c2ecb82f21eb2920a53a86895 SHA512 2d4584c004776ac72e08ab6ffa7ade66e498a170a71310c4ef36fe6d648ab2a19dcabf4292187d7b260783b4f4b1318a35c628fa860fa57ffd47a7d998566e12
+DIST nvtop-3.0.2.tar.gz 241421 BLAKE2B 6d0c1101bfd9401ab8174721840c9b70f34b334e3d8f3d4e79f0df9a726118a43911adf6bc8c839e5259d780783abe7daa6622d31057cb2906e2c56d655f4c03 SHA512 e5f23796c37b21f9e16f90b6aecce010239f736e60698fec22f663afef24439680132cb4bf08c56b9c05a9a69fa81421fed46c392adc06435f5209552337caed
diff --git a/sys-process/nvtop/nvtop-3.0.2.ebuild b/sys-process/nvtop/nvtop-3.0.2.ebuild
new file mode 100644
index 000000000..395e8ba17
--- /dev/null
+++ b/sys-process/nvtop/nvtop-3.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="NVIDIA GPUs htop like monitoring tool"
+HOMEPAGE="https://github.com/Syllo/nvtop"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Syllo/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Syllo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="unicode video_cards_intel video_cards_amdgpu video_cards_nvidia video_cards_freedreno"
+
+RDEPEND="
+ video_cards_intel? ( virtual/udev )
+ video_cards_amdgpu? ( x11-libs/libdrm[video_cards_amdgpu] )
+ video_cards_nvidia? ( x11-drivers/nvidia-drivers )
+ video_cards_freedreno? ( x11-libs/libdrm[video_cards_freedreno] )
+ sys-libs/ncurses:0=
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCURSES_NEED_WIDE=$(usex unicode)
+ -DINTEL_SUPPORT=$(usex video_cards_intel)
+ -DNVIDIA_SUPPORT=$(usex video_cards_nvidia)
+ -DAMDGPU_SUPPORT=$(usex video_cards_amdgpu)
+ -DMSM_SUPPORT=$(usex video_cards_freedreno)
+ )
+
+ cmake_src_configure
+}
diff --git a/sys-process/nvtop/nvtop-9999.ebuild b/sys-process/nvtop/nvtop-9999.ebuild
index e2d0d4176..395e8ba17 100644
--- a/sys-process/nvtop/nvtop-9999.ebuild
+++ b/sys-process/nvtop/nvtop-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,12 +19,13 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="unicode video_cards_intel video_cards_amdgpu video_cards_nvidia"
+IUSE="unicode video_cards_intel video_cards_amdgpu video_cards_nvidia video_cards_freedreno"
RDEPEND="
video_cards_intel? ( virtual/udev )
video_cards_amdgpu? ( x11-libs/libdrm[video_cards_amdgpu] )
video_cards_nvidia? ( x11-drivers/nvidia-drivers )
+ video_cards_freedreno? ( x11-libs/libdrm[video_cards_freedreno] )
sys-libs/ncurses:0=
"
@@ -41,6 +42,7 @@ src_configure() {
-DINTEL_SUPPORT=$(usex video_cards_intel)
-DNVIDIA_SUPPORT=$(usex video_cards_nvidia)
-DAMDGPU_SUPPORT=$(usex video_cards_amdgpu)
+ -DMSM_SUPPORT=$(usex video_cards_freedreno)
)
cmake_src_configure