aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-08-02 20:43:44 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-08-02 20:44:27 +0200
commit3bd7494b245565c56ae81b915b5f972ab3d3f2d2 (patch)
tree3af4d6561b8994ff223df544f12f575a38435618 /www-apps
parentapp-text/komikku: drop 1.51.1 (diff)
downloadguru-3bd7494b245565c56ae81b915b5f972ab3d3f2d2.tar.gz
guru-3bd7494b245565c56ae81b915b5f972ab3d3f2d2.tar.bz2
guru-3bd7494b245565c56ae81b915b5f972ab3d3f2d2.zip
www-apps/pleroma: Need git for fetching some deps, need -fPIC under glibc
Closes: https://bugs.gentoo.org/937130 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/pleroma/pleroma-2.7.0-r1.ebuild7
-rw-r--r--www-apps/pleroma/pleroma-9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/www-apps/pleroma/pleroma-2.7.0-r1.ebuild b/www-apps/pleroma/pleroma-2.7.0-r1.ebuild
index 0465384fa..80e352770 100644
--- a/www-apps/pleroma/pleroma-2.7.0-r1.ebuild
+++ b/www-apps/pleroma/pleroma-2.7.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit mix optfeature
+inherit mix optfeature flag-o-matic
DESCRIPTION="ActivityPub social networking software compatible with other Fediverse software"
HOMEPAGE="https://pleroma.social/"
@@ -28,6 +28,7 @@ BDEPEND="
dev-build/cmake
>=dev-util/rebar-3.20.0-r1
dev-elixir/hex
+ dev-vcs/git
"
DEPEND="
media-libs/vips:=
@@ -71,6 +72,10 @@ src_prepare() {
echo 'config :tzdata, :data_dir, "/var/lib/pleroma/tzdata"' >> config/prod.exs || die
echo "import Config" > config/prod.secret.exs || die
+
+ # Needs -fPIC under glibc for exile library
+ # https://bugs.gentoo.org/937130
+ append-flags -fPIC
}
src_compile() {
diff --git a/www-apps/pleroma/pleroma-9999.ebuild b/www-apps/pleroma/pleroma-9999.ebuild
index 0465384fa..80e352770 100644
--- a/www-apps/pleroma/pleroma-9999.ebuild
+++ b/www-apps/pleroma/pleroma-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit mix optfeature
+inherit mix optfeature flag-o-matic
DESCRIPTION="ActivityPub social networking software compatible with other Fediverse software"
HOMEPAGE="https://pleroma.social/"
@@ -28,6 +28,7 @@ BDEPEND="
dev-build/cmake
>=dev-util/rebar-3.20.0-r1
dev-elixir/hex
+ dev-vcs/git
"
DEPEND="
media-libs/vips:=
@@ -71,6 +72,10 @@ src_prepare() {
echo 'config :tzdata, :data_dir, "/var/lib/pleroma/tzdata"' >> config/prod.exs || die
echo "import Config" > config/prod.secret.exs || die
+
+ # Needs -fPIC under glibc for exile library
+ # https://bugs.gentoo.org/937130
+ append-flags -fPIC
}
src_compile() {