aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-05-24 14:29:44 -0400
committerJulien Roy <julien@jroy.ca>2024-05-24 14:35:56 -0400
commit3f07a28bc0ea114e5e280c37b0231e4a3c373783 (patch)
tree879cadb9c4d84e4b6acb800f6b1f72759f6bb113 /www-apps
parentnet-im/maubot: new package, add 0.4.2 (diff)
downloadguru-3f07a28bc0ea114e5e280c37b0231e4a3c373783.tar.gz
guru-3f07a28bc0ea114e5e280c37b0231e4a3c373783.tar.bz2
guru-3f07a28bc0ea114e5e280c37b0231e4a3c373783.zip
www-apps/nitter: treeclean
Bug: https://bugs.gentoo.org/907344 Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nitter/Manifest2
-rw-r--r--www-apps/nitter/files/nitter.conf.example48
-rw-r--r--www-apps/nitter/files/nitter.initd30
-rw-r--r--www-apps/nitter/files/nitter.service12
-rw-r--r--www-apps/nitter/metadata.xml8
-rw-r--r--www-apps/nitter/nitter-2023.05.20.ebuild64
-rw-r--r--www-apps/nitter/nitter-2023.07.12.ebuild64
7 files changed, 0 insertions, 228 deletions
diff --git a/www-apps/nitter/Manifest b/www-apps/nitter/Manifest
deleted file mode 100644
index 7e3752ba7..000000000
--- a/www-apps/nitter/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST nitter-2023.05.20.tar.gz 1184325 BLAKE2B aefeade24bd8b34303d3b0bd1280ad48e2b898c603bbaf5bf93a712fc0e59aec507340209483a72378bd4e72f94b262f13c37bca6323e07911e1f50d4cf556fd SHA512 03cbfef15eed61092cc03549755f3eb96be42999d1af652210df112fe41aea4b68aadd7a45faedb84702e8b852fa09c7ee29c908c983a5a9a8ec2d509d063c9a
-DIST nitter-2023.07.12.tar.gz 1184928 BLAKE2B 02658a4d89205c5ac8d302e51b9628714c72e2bedb40785c0018ccddc3ca74185e1894228792e05e0c67f6527f7bd98cd10f76a9a880ee2c2083f43948fbf0ca SHA512 9ac70ae5e5f954e14dd1dd8cfc82d8ec8058ae228b61f5639a23a5959d7611833f99b7e6dd90b6cc26ab5ed4244c2027d5b5ca91daac338f877b63eabd275f8b
diff --git a/www-apps/nitter/files/nitter.conf.example b/www-apps/nitter/files/nitter.conf.example
deleted file mode 100644
index 277f55773..000000000
--- a/www-apps/nitter/files/nitter.conf.example
+++ /dev/null
@@ -1,48 +0,0 @@
-# This is an example. Copy this file to /etc/nitter/nitter.conf and edit to
-# match your preferences.
-
-[Server]
-address = "0.0.0.0"
-port = 8080
-https = false # disable to enable cookies when not using https
-httpMaxConnections = 100
-staticDir = "/usr/share/nitter/public"
-title = "nitter"
-hostname = "nitter.net"
-
-[Cache]
-listMinutes = 240 # how long to cache list info (not the tweets, so keep it high)
-rssMinutes = 10 # how long to cache rss queries
-redisHost = "localhost" # Change to "nitter-redis" if using docker-compose
-redisPort = 6379
-redisPassword = ""
-redisConnections = 20 # connection pool size
-redisMaxConnections = 30
-# max, new connections are opened when none are available, but if the pool size
-# goes above this, they're closed when released. don't worry about this unless
-# you receive tons of requests per second
-
-[Config]
-hmacKey = "secretkey" # random key for cryptographic signing of video urls
-base64Media = false # use base64 encoding for proxied media urls
-enableRSS = true # set this to false to disable RSS feeds
-enableDebug = false # enable request logs and debug endpoints
-proxy = "" # http/https url, SOCKS proxies are not supported
-proxyAuth = ""
-tokenCount = 10
-# minimum amount of usable tokens. tokens are used to authorize API requests,
-# but they expire after ~1 hour, and have a limit of 187 requests.
-# the limit gets reset every 15 minutes, and the pool is filled up so there's
-# always at least $tokenCount usable tokens. again, only increase this if
-# you receive major bursts all the time
-
-# Change default preferences here, see src/prefs_impl.nim for a complete list
-[Preferences]
-theme = "Nitter"
-replaceTwitter = "nitter.net"
-replaceYouTube = "piped.kavin.rocks"
-replaceReddit = "teddit.net"
-replaceInstagram = "bibliogram.art"
-proxyVideos = true
-hlsPlayback = false
-infiniteScroll = false
diff --git a/www-apps/nitter/files/nitter.initd b/www-apps/nitter/files/nitter.initd
deleted file mode 100644
index 1d26ed1cf..000000000
--- a/www-apps/nitter/files/nitter.initd
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-: ${NITTER_CONF_FILE:="/etc/nitter/${RC_SVCNAME}.conf"}
-export NITTER_CONF_FILE
-
-command="/usr/bin/nitter"
-command_background=yes
-command_user="nitter:nitter"
-pidfile="/run/${RC_SVCNAME}.pid"
-
-logpath="/var/log/nitter"
-output_log="${logpath}/${RC_SVCNAME}.log"
-error_log="${output_log}"
-
-depend() {
- need redis
- use net
-}
-
-start_pre() {
- checkpath -do "${command_user}" "${logpath}"
- checkpath -fo "${command_user}" "${output_log}"
-
- if [ ! -f "${NITTER_CONF_FILE}" ]; then
- eerror "Configuration file '${NITTER_CONF_FILE}' not found"
- return 1
- fi
-}
diff --git a/www-apps/nitter/files/nitter.service b/www-apps/nitter/files/nitter.service
deleted file mode 100644
index 443fecd49..000000000
--- a/www-apps/nitter/files/nitter.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Nitter
-After=network.service
-Requires=redis.service
-
-[Service]
-User=nitter
-Environment="NITTER_CONF_FILE=/etc/nitter/nitter.conf"
-ExecStart=/usr/bin/nitter
-
-[Install]
-WantedBy=multi-user.target
diff --git a/www-apps/nitter/metadata.xml b/www-apps/nitter/metadata.xml
deleted file mode 100644
index 5b8c50c6d..000000000
--- a/www-apps/nitter/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">zedeus/nitter</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/www-apps/nitter/nitter-2023.05.20.ebuild b/www-apps/nitter/nitter-2023.05.20.ebuild
deleted file mode 100644
index 7f90476a8..000000000
--- a/www-apps/nitter/nitter-2023.05.20.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit nimble systemd
-
-COMMIT="e3b3b38a2d43a83b5fc2239ab41e864ee686fb2f"
-DESCRIPTION="Alternative front-end for Twitter"
-HOMEPAGE="https://github.com/zedeus/nitter"
-SRC_URI="https://github.com/zedeus/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RESTRICT="test"
-PROPERTIES="test_network"
-
-RDEPEND="
- acct-user/nitter
- dev-db/redis
-"
-DEPEND="
- dev-nim/flatty
- dev-nim/jester
- dev-nim/jsony
- dev-nim/karax
- dev-nim/markdown
- dev-nim/nimcrypto
- dev-nim/packedjson
- dev-nim/redpool
- dev-nim/sass
- dev-nim/supersnappy
- dev-nim/zedeus_redis
- dev-nim/zippy
-"
-
-src_configure() {
- nimble_src_configure
-
- # Error: unhandled exception: cannot open: public/lp.svg
- ln -s "${S}"/public "${BUILD_DIR}/public" || die
-}
-
-src_compile() {
- nimble_src_compile
- enim r tools/gencss
- enim r tools/rendermd
-}
-
-src_install() {
- nimble_src_install
-
- newinitd "${FILESDIR}"/nitter.initd ${PN}
- systemd_dounit "${FILESDIR}"/nitter.service
-
- insinto /etc/nitter
- doins "${FILESDIR}"/nitter.conf.example
-
- insinto /usr/share/nitter
- doins -r public
-}
diff --git a/www-apps/nitter/nitter-2023.07.12.ebuild b/www-apps/nitter/nitter-2023.07.12.ebuild
deleted file mode 100644
index 66560453d..000000000
--- a/www-apps/nitter/nitter-2023.07.12.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit nimble systemd
-
-COMMIT="afbdbd293e30f614ee288731717868c6d618b55f"
-DESCRIPTION="Alternative front-end for Twitter"
-HOMEPAGE="https://github.com/zedeus/nitter"
-SRC_URI="https://github.com/zedeus/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RESTRICT="test"
-PROPERTIES="test_network"
-
-RDEPEND="
- acct-user/nitter
- dev-db/redis
-"
-DEPEND="
- dev-nim/flatty
- dev-nim/jester
- dev-nim/jsony
- dev-nim/karax
- dev-nim/markdown
- dev-nim/nimcrypto
- dev-nim/packedjson
- dev-nim/redpool
- dev-nim/sass
- dev-nim/supersnappy
- dev-nim/zedeus_redis
- dev-nim/zippy
-"
-
-src_configure() {
- nimble_src_configure
-
- # Error: unhandled exception: cannot open: public/lp.svg
- ln -s "${S}"/public "${BUILD_DIR}/public" || die
-}
-
-src_compile() {
- nimble_src_compile
- enim r tools/gencss
- enim r tools/rendermd
-}
-
-src_install() {
- nimble_src_install
-
- newinitd "${FILESDIR}"/nitter.initd ${PN}
- systemd_dounit "${FILESDIR}"/nitter.service
-
- insinto /etc/nitter
- doins "${FILESDIR}"/nitter.conf.example
-
- insinto /usr/share/nitter
- doins -r public
-}